cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

MathCAD 15 3D not function

ptc-5157738
1-Newbie

MathCAD 15 3D not function

Windows XP SP3, MathCAD 15 M20

I just found the 3D plot doesn't function. See attached picture that is from quicksheet.

Double click the plot area, pop up a message "Failed to launch server application".

I have uninstall and reinstall several times, but cannot solve this problem.

7 REPLIES 7

Seems to be an old/known problem - see this thread from 2010: http://communities.ptc.com/thread/32771

The poster solved the problem by uninstalling MC15, installed MC14 and upgraded to MC15 - by no means an desireable and accaptable solution.

The usual advice given here with problems with 3D graphs (uncheck border, reduce color depth, disable graphics acceleration in driver) seems not to apply here - it addresses problems with 3D graphs under Win7. See here: http://communities.ptc.com/message/153226#153226

There is one solution in the above thread you could try as it may apply to your problem, too and that is registering the glr.dll:

1. Go to Start>Run and type in cmd to bring up the command window (you should have Admin rights).
2. Type in the path cd c:\program files\Mathcad\Mathcad 15\ (or wherever Mathcad is installed).
3. Type regsvr32 glr.dll.
4. A dialog should appear that states it was successful
“DllRegisterServer in glr.dll succeeded”.
This could fix the problem. However, each time Mathcad is uninstalled/reinstalled, you may need to register the dll again.


Thanks.

I tried the last solution -- register glr.dll. Now the plot area shows x,y,z axis, but no plot(data) shows out. See attached picture.

Double click the plot area, pop up 3D-Plot format dialog.

So you could try one of the other points in the aforementioned thread (http://communities.ptc.com/message/153226#153226)

The easiest would be to uncheck "Show border"

I unchecked the "Show Border". It doesn't work

There is an error tip under the plot: "abnormal with the calling object ", something like this.

The uncheck border tip usually applies to the 3D problem with Win7, but it was worth a try.

Maybe its time now that you contact PTC support with that problem. If there is a solution please post it here.

http://www.ptc.com/support/mathcad_supportCenter.htm

http://blogs.ptc.com/2011/09/22/how-to-use-the-brand-new-online-mathcad-support-center/

One last idea: did you installed MC15 as administrator or as a user with limited rights?

I installed MC15 as administrator.

wei tong wrote:

I installed MC15 as administrator.

And I guess you had installed the preliminaries as well (MDAC 2.8 or higher, and the exact versions: .NET 3.5 SP1, MSXML 4.0 SP3). I'm not sure but I think in contrary to MC14 MC15 will complain at installation time if something is missing.

Unfortunately my "wisdom" is at an sudden end.

I don't think that it would make sense to register other .dll's in the Mathcad15 directory. I just looked at my installation (WinXP SP3, too) and of the 120 dll's in the MC15 dir, only three are registered (automation.dll, glr.dll and mclauncher.dll) along with mathcad.exe and tabler.ocx.

BTW, I have used the free tool RegDLLView from www.nirsoft.net to get that information.

Getting in contact with PTC seems appropriate now.

Announcements
Check out the latest
Mathcad Tip
"PTC Mathcad 15 / Prime 1-6 Update."