cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Mathcad 15 M020 does not work with the /3Gb switch in boot.ini

Highlighted
Newbie

Mathcad 15 M020 does not work with the /3Gb switch in boot.ini

I used to run very large worksheets with the /3gb switch in boot.ini using Mathcad 15. But now in M020, the screen display no longer switches to VGA, indicating the OS is operating in its normal mode, not /3gb.

Any ideas?

Bill

4 REPLIES 4
Highlighted

Re: Mathcad 15 M020 does not work with the /3Gb switch in boot.ini

BTW, this was after rebooting the XP SP3 computer as well.

Bill

Highlighted

Re: Mathcad 15 M020 does not work with the /3Gb switch in boot.ini

You may need to post it as a bug and/or let Jakub know (the new Mona in the forum).

Highlighted

Re: Mathcad 15 M020 does not work with the /3Gb switch in boot.ini

There were no changes in Mathcad 15.0 M020 that I could think of that would cause this. The best would be to contact tech support.

Can you describe "the screen no longer switches to VGA"? When did that used to happen? When starting Mathcad? If you are running OS with /3Gb switch, it will apply to all applicaitons -- not just Mathcad.

Are you not able to run the worksheets you used to run before?

One way to determine whether this is related to M020 or changes in OS is to re-install M010 and try it (I know you are not looking forward to this).

I'll ask development to look into this.

-Jakov

Highlighted

Re: Mathcad 15 M020 does not work with the /3Gb switch in boot.ini

Jakov, here is the PTC info on the 3 gb switch which only works if you have 4 GB of RAM on Windows XP 32 bit.

https://www.ptc.com/appserver/cs/view/solution.jsp?n=111330

Basically Mathcad can take over an entire 3 GB of RAM just leaving a minimum of a couple hundred kilobytes to the Windows XP 32 bit operating system. This is why it forces you into the straight VGA mode.

In the past, at least up until September of 2011, I was able to use it fine in Mathcad. I am not sure which version I was running, probably the latest at the time. The screen always came up in straight VGA mode so I had to do a lot of scrolling when I had a problem, but it worked fine.

It is not true that it will allocate to all applications, but it used to work fine with Mathcad 15, which apparently was built to work with the 3 gb switch.

There is no sense trying to run old worksheets because it is obviously not working correctly anyway.

I may try to install M010 on my machine at home, and see if it works there. (I have a license for it there as well.) But I don't have time to mess with it here at work. I am just trying to reduce the size of the problem, which appears to be working so far.

Bill

Announcements