cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Prime backwards compatibility - solved? Or at least hacked

DJF
Alexandrite

Prime backwards compatibility - solved? Or at least hacked

Given how little versions changed, it has frustrated us all that we cannot save in older versions.  I suspect this is largely a marketing ploy to force upgrades and new purchases. And, probably controlled by a simple version check.  So after a little thinking, digging and experimenting, I have been able to open 5.0 files in 4.0.  I haven't played with it much and I'm sure it's limited - but it might help someone someday.

  

With the new version file

a.) Change the extension to .zip

b.) Unzip to a folder

c.) Delete app.xml in docProps folder

 

With the older version

i.) Save any file

ii.) Change the extension to .zip

iii.) Unzip to a folder

iv.) Copy the app.xlm in the docProps folder

v.) Paste this 'old' app.xlm into the folder where you deleted the last one.  You should just be able to re-use this file anytime you want to do this.

 

Go back to the 'new' version folder:

Re-Zip all folders and files that had been unzipped.

Change extension from .zip to .mcdx

Open in old version

 

In short, replace the app.xlm file with a version from the older mathcad

 

Success! 

(Use at your own risk, no guarantees nothing else changed.  Obviously won't bring new features across)

Announcements