cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Saved my .xmcd file and suddenly it says 0KB?

Highlighted
Newbie

Saved my .xmcd file and suddenly it says 0KB?

Hi.

I went for an 6 hour exam here in december and after 4,5 hours i saved my work two places on my computer to be sure it saved it properly.

I then closed mathcad with no problem but when i tried to open my work again, it said it couldnt read the file and it was only 0KB large.. - i couldnt fix it in time and now i must go to re examination.

I use MathCAD 14.0 - anyone else who has encounter this major issue? - i've tried it two times now with another file.

plz help, i dont want to make the same mistake twice

3 REPLIES 3

Re: Saved my .xmcd file and suddenly it says 0KB?

The 0kB file problem has been reported before, but we don't know exactly what causes it. In the future save the file, and check the file size before closing the worksheet. If it's 0kB then copy the entire worksheet to the clipboard and paste it into a new worksheet, and try saving that.

As a general piece of advice, IMO there is no piece of software that has ever been written that is so stable that I would work in it for 4.5 hours without saving my work.

Re: Saved my .xmcd file and suddenly it says 0KB?

It can be a real problem.

I set my autosave to be somewhere between 5 and 20 mins (that latter being my corporate auto-screenlock time.

In a managed environment you may find that the save actually goes to a temp file before being copied across to it's final destination (I think Mathcad does that bit) but that copy across fails because of bad 'timing' or a racy condition such that the final desitination has zero (e.g. the temp file has been deleted by the corporate environment process close).

I've had the problem with a remote desktop (rdt) operation (I was testing and install on a remote machine) where on logout, there was a prompt from Mathcad to save the file in work, which I accepted, but the content then dissapeared. I suspect the rdt closed down mathcad process before the temp file copy.

Anyway, so having set the autosave, you can at least get that one back (having noticed the 0kb issue) by taking a copy of the autosave file (google for it's location), and then opening that version which will only be a few minutes old.

Hope this helps - ceratinly switch on autosave, sometimes it helps.

I also keep lots of revisons <file>, <file>r1, <file>r2, <file>r3, ... (I'm upto r26 on some)

Re: Saved my .xmcd file and suddenly it says 0KB?

I can advise you the following:

* Enable "Autosave" option of the working file after a certain time interval (in main menu select "Tools" -> "Preferences" -> "Save").

Pic_1.png

Pic_2.png

* Use "Save Clipboard" program to save the contents of the buffer in which to place the copy of the entire contents of the worksheet (use shortcut "Ctrl+A" then "Ctrl+C" in Mathcad). When you save the file in this program, then give it a name, but without the file extension. Then, any time you can open the file with the stored information in the buffer and paste the contents of the buffer in a clean Mathcad worksheet.

Pic_3.png

Announcements