cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

VBScript runtime error Object required: 'ComboBox'

Visitor

VBScript runtime error Object required: 'ComboBox'

I have Mathcad 15 and Windows 10 installed on my computer.  I am trying to use a Mathcad program which has some ComboBox's and/or drop-down lists embedded in it, and keep getting error messages (pasted below) about Microsoft VBScript runtime error...Object required: 'ComboBox'.  Any ideas how to fix this problem?   

 

6 REPLIES 6

Re: VBScript runtime error Object required: 'ComboBox'

There are no scripted components in the sheet you posted. Its just a top menu file which calls a couple of other worksheets via hyperlinks.

Re: VBScript runtime error Object required: 'ComboBox'

 

Werner - Thanks for your reply.  Sorry, I didn't realize it was just the top menu file I sent.  I attached the entire Mathcad program here, with all the other associated worksheets and reference files.  The problem I have is when I open the "PSbeam" Mathcad XML Document, and then double click the "Single Web Beam" icon (and then click "No" to not disable evaluation of objects), that brings me to the "Data Input" part of the program, and that's where I'm getting the VBScript runtime error Object required 'ComboBox' error messages. 

Re: VBScript runtime error Object required: 'ComboBox'

When I do what you describe it all looks like its working OK.

See at the end what  I am seeing. I can enter a filename (abc) in the textbox, when I press the button "Refresh File List" this file appears in the left Listbox. Also a zerobyte file named abc.dat is created in the "I-Beam Data Files" subdirectory.

I can select a file in the listbox and press  the button "Read Data File" and it seems to work. At least I don't experience any errors.

So the files and scripts seem to be OK. It may have to do with your installations. In the past (you may search for it in this forum) there often was given the advise to re-register the components using a command I did't remember. maybe this helps.

B.jpg

Re: VBScript runtime error Object required: 'ComboBox'

ok thanks

Highlighted

Re: VBScript runtime error Object required: 'ComboBox'

I'm seeing the same issue for users that are running Windows 10. We have many calcs that were created on Windows 7 and Office 2010 or 2013 and work fine still on that OS. Now users that have Windows 10 and Office 2016 are having VbScript runtime errors, failed to launch server application, and generally poor performance with embedded Excel objects.

Re: VBScript runtime error Object required: 'ComboBox'

I have the same problem,

This problem shows up only in combo boxes (not list box, sliders , radio controls...) 

I guess that is because we are trying to made new code on script which may not 100% supported by mathcad

I could not find the solution yet but the only think I am sure about is that there is nothing problem in your mathcad file or in your code because I have more than 20 files with a lots of combo boxes which are working in my PC at office (windows 10 ) but non of them working on my laptop with the same error (again windows 10 ) also some of my colleague PCs can open these files and some not! (all windows 7 ) so the only thing I understood there is something about windows or Microsoft script.

I saw somewhere talks about MSXML4 or Microsft net frame work which is needed to install on your pc for mathcad

finally your file works on my PC without any problem as well  so please let me know if you find the solution

thanks