cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Why won't it solve?

SOLVED
Hum
Regular Member

Why won't it solve?

I had to revert back to using freeware after hitting this snag with Prime 4.0... I don't understand what the difficulty is at step 5. Troubleshooting further down the page was successful after using new variables, so it seems to be a problem with my variables...

 

I even tried clearing the variables like my reference "Essential PTC Mathcad Prime 3.0" textbook suggests. Any help would be greatly appreciated in getting me back going... 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Why won't it solve?

The problem is caused by Prime's infamous "auto labelling". Especially in combination with symbolic calculations this "feature" is usually more pain than help.

The I0 on the left hand side is labelled as "variable" but the I0 after "solve," is labelled "-", meaning "automatic". For the symbolics you are demanding to solve for a variable which does not even occur in the system of equations.

You have to change the label of one of the I0 to match the other, e.g. you may change the label of the second I0 from "-" to "variable". After doing so you get the solution you are looking for.

B.png

BTW, I wonder why you are using symbolics while you are just after numeric results. You may consider using Primes numerical methods like "root" or a "solve block". They are more rebust wrt labelling and can deal much better with units.

 

View solution in original post

14 REPLIES 14

Re: Why won't it solve?

The problem is caused by Prime's infamous "auto labelling". Especially in combination with symbolic calculations this "feature" is usually more pain than help.

The I0 on the left hand side is labelled as "variable" but the I0 after "solve," is labelled "-", meaning "automatic". For the symbolics you are demanding to solve for a variable which does not even occur in the system of equations.

You have to change the label of one of the I0 to match the other, e.g. you may change the label of the second I0 from "-" to "variable". After doing so you get the solution you are looking for.

B.png

BTW, I wonder why you are using symbolics while you are just after numeric results. You may consider using Primes numerical methods like "root" or a "solve block". They are more rebust wrt labelling and can deal much better with units.

 

View solution in original post

Re: Why won't it solve?

One way to prevent such annoying situations is by changing the appearance of each of the 7 possible 'labels' such that they are readily distinguishable.

By default 'automatic' and 'variable' use exactly the same font, colour, and size. The same is true for 'system' and 'keyword', and their difference to 'function' isn't particularly obvious.

You might consider changing the colour of 'automatic' to orange, so that it sticks out.

While you're at it: Note that 'unit' is blue and italic, it should be upright (roman) style according to international standards...

 

Success!

Luc

Re: Why won't it solve?


@LucMeekes wrote:

You might consider changing the colour of 'automatic' to orange, so that it sticks out.

As far as I know you can't change the color of "automatic' but if you have a different appearance of all six possibilities you can easily see if the automatic had chosen the wrong choice.

Re: Why won't it solve?

Check this,

LM_20190204_Labels.png

and the Prime4 file attached.

 

Success!
Luc

Re: Why won't it solve?

I guess you just colored that single variable. As you can see in Pic1 in the expression x=y+z the y is labelled "-" meaning "auto" and still is colored black (because auto labelling thinks its a variable and variables are black).

Pic2 shows that I only can change the display of the six types listed, not for "auto".

 

P.S.: I am not allowed to embed pictures in posts as I get the error that I reached my limit of 1000 pictures!? Not sur what will happen to my answers in the various threads if I delete the pictures which were automatically collected in "My Photos".

 

Fortunately I can still attach pictures.

 

Re: Why won't it solve?


@Werner_E wrote:

I guess you just colored that single variable.

 

 


Yes, I did.

I see what you mean. So Variable's would have to be coloured, rather than Automatic's...

 

No that doesn't work either.

Here's what happens if I create a new set, and label appropriately:

LM_20190204_nLabels.png

The upright (roman) style of Unit is kept. The rest of my changes is just forgotten.

 

Considering Prime, Mathcad was way ahead of its time...

or

Prime is just a (too big) step backwards. But we know that for some time now.

 

Luc

Re: Why won't it solve?


Here's what happens if I create a new set, and label appropriately:

 

The upright (roman) style of Unit is kept. The rest of my changes is just forgotten.

 


You have to set the new style via Menu: "Math Formatting" - "Label styles" as shown in one of the pictures in my other post. This seems to work. Unlike as in real Mathcad changing the style simply in one expression does not affect all the other expressions of equal style. Thats a small improvement in Prime IMHO.

 


Considering Prime, Mathcad was way ahead of its time...

or

Prime is just a (too big) step backwards. But we know that for some time now.

 

Luc


Fully agreed on.

 

P.S.: I just tried deleting one of the pics in my "gallery" of 1000 pictures and as expected this damages the post it originally belonged to (my first answer in this thread here). The pic is replaced by a huge dummy pic. So deleting the pics in my gallery so that I would be allowed to embed pictures again is not a solution as it would render my previous answers useless. A ridiculous situation - hope Jaime Lee or a mod will come up with a suitable solution for this soon.

 

Re: Why won't it solve?

Obviously, PTC maintains a maximum threshold of helpfulness which the corporation endorses. You've apparently reached that threshold, the community loves you for it, but PTC has capped your further dissemination of insight in the same vein as the 15 to Prime transition has unfolded. 

Anyhow, from my experience your not going to get any traction from PTC so I would recommend just creating a new account if you intend to side step their apparent cultural quirks... 

As a side note, in the video game world when one beats a game and goes in for another round, the player often gets some emblem on their avatar and is henceforth regarded to as possessing the first level of "prestige"... I think you've done this in the PTC community good Sir... Smiley Happy

https://support.activision.com/articles/en_US/FAQ/Prestige-in-Call-of-Duty-WWII

 

Re: Why won't it solve?


@Hum wrote:

Obviously, PTC maintains a maximum threshold of helpfulness which the corporation endorses. 

 

Anyhow, from my experience your not going to get any traction from PTC so I would recommend just creating a new account if you intend to side step their apparent cultural quirks... 

As a side note, in the video game world when one beats a game and goes in for another round, the player often gets some emblem on their avatar and is henceforth regarded to as possessing the first level of "prestige"... I think you've done this in the PTC community good Sir... Smiley Happy

https://support.activision.com/articles/en_US/FAQ/Prestige-in-Call-of-Duty-WWII

 


Werner has joined the ranks of a select few:

  • Tom Gutman departed in disgust
  • Richard J struggled on until blantant greed drove him away
  • Only Jean (JMG) managed to get actually banned from the forum. . .

Kudos, Werner!