cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

polyfit not plotting, all arrays verified

dmaynard
4-Participant

polyfit not plotting, all arrays verified

I am trying to get a polyfit curve from attached excel data, page 12. Data points read in fine and plot. I am getting a plotting error when I try to graph the polyfit function. Using Mathcad Prime 3.1. My goal is to generate an equation that approximates the data points for use in control scheme. I will need to display the coefficients as well. Thank you in advance for your assistance.

1 ACCEPTED SOLUTION

Accepted Solutions

I had to fake your time data, couldn't figure out what [@normal] meant.

 

But polyfit works.  You can see coefficients with polyfitc

View solution in original post

8 REPLIES 8

May be this help you

psi-tt.png

dmaynard
4-Participant
(To:ValeryOchkov)

Sorry, look at page 12 for the error location.


@dmaynard wrote:

Sorry, look at page 12 for the error location.


Sorry but I see only 11 pages!

And I think you not correct plot two vectors and one function. See please my picture!

 

Sorry - I go to bet...

dmaynard
4-Participant
(To:ValeryOchkov)

I corrected the upload.

dmaynard
4-Participant
(To:ValeryOchkov)

That particular plot I will be using piecewise functions later on for comparison. Not worried about it right now.

I had to fake your time data, couldn't figure out what [@normal] meant.

 

But polyfit works.  You can see coefficients with polyfitc

View solution in original post

I am trying to replicate your plot but I am still unable. Plot is still failing and I do not understand why.

dmaynard
4-Participant
(To:dmaynard)

Nevermind, I figured it out. I had to create second array for polyfit plot points. Thank you. I appreciate all the help.

Announcements
Check out the latest
Mathcad Tip
"PTC Mathcad 15 / Prime 1-6 Update."