cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

All edges in drawing don't show

SOLVED
Highlighted
Regular Member

All edges in drawing don't show

Hi,

 

I have a strange problem, and I've encountered it before. In a drawing view with "No Hidden" Display style the edges of some parts sometimes dissappear. See the picture below. If I select the part in the drawing I can seen the outline (green on the right), but it won't show by itself. I've tried with "Display style" Wireframe and Hidden. In these I can see the edges. It seems that the edges are considered behind something, which as seen in the colour image is clearly not the case. Any ideas on solving this? I run Creo 3, M050.

 

Capture.JPG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: All edges in drawing don't show

Usually it shows up worse in 3D type (ISO) views. Orthographic views are generally better at working out the line display issue.

We see it all the time with our hardware.

For simple assemblies, I'll make a component flexible and adjust a dimension to eliminate the interference. For complicated stuff, I try adjusting view orientation if I can or just not use the 3D view.

When I used to work with sheet metal (like some of your stuff looks like), I used to hate inserts and what-not that was press fit or deformed fit for that reason.

The work arounds are usually painful, like "eliminating all interferences", creating draft geometry using "project" or use edge.

iso-int.jpg

normal-int.jpg


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)

View solution in original post

5 REPLIES 5
Highlighted

Re: All edges in drawing don't show

Do you have any interferences in the assembly? It's very common to see this when there are interferences, sometimes not specifically in that spot.


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)
Highlighted

Re: All edges in drawing don't show

Well I guess there may be interferences at some points. They do however show again if the view angle is changed.

Highlighted

Re: All edges in drawing don't show

Usually it shows up worse in 3D type (ISO) views. Orthographic views are generally better at working out the line display issue.

We see it all the time with our hardware.

For simple assemblies, I'll make a component flexible and adjust a dimension to eliminate the interference. For complicated stuff, I try adjusting view orientation if I can or just not use the 3D view.

When I used to work with sheet metal (like some of your stuff looks like), I used to hate inserts and what-not that was press fit or deformed fit for that reason.

The work arounds are usually painful, like "eliminating all interferences", creating draft geometry using "project" or use edge.

iso-int.jpg

normal-int.jpg


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)

View solution in original post

Highlighted

Re: All edges in drawing don't show

Thanks again. I'm not a big fan of "dirty" workarounds as they tend to break at a later stage, leading to further effort. I guess we'll have o live with this until PTC corrects this issue.

Highlighted

Re: All edges in drawing don't show

This has to do with changes to "fast hidden lines removal" (fasthlr) in Creo.  In Wildfire this worked great.  In Creo they broke it.  It looks like maybe it's been fixed now, so it might be worth retesting.  (If I remember right, measuring the distance between objects in Creo 3 with this enabled could sometimes be very incorrect.)

https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS200990

https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS111884

https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS164326

https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS187767

Announcements
Business Continuity with Creo: Learn more about it here.