cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Datum planes in a hidden layer will not hide in the model!

SOLVED

Re: Datum planes in a hidden layer will not hide in the model!

Although I don't see the video there anymore... can you see it?

Went into annotate, annotation feature, selected datum symbol under definition, selected part surface, named datum..etc.

Re: Datum planes in a hidden layer will not hide in the model!

Hi Antonius,

For some reason the video you made to show an alternate GDT plane tol is not playing for me (yet your bike ride one did; nice by the way).

I have struggled too with how getting the base GTOL datum set and showing up properly in the model and drawing. I want it normally off in the model and on in the drawing and would expect to control this with layers like normal but it is quirky so an alternate method would be great.

Any chance you could send me the video directly? email -

Regards, Brent

Re: Datum planes in a hidden layer will not hide in the model!

Sorry Ulaengin...

That question was actually for Antonius. I'll take a look at the video and see if I can reproduce your problem.

Thanks!

-Brian

Re: Datum planes in a hidden layer will not hide in the model!

Hi Brian. When you assign the datum tag annotation to one of the primary datums, it does not follow any rhyme or reason on how or when they are visible or not. It is simply best to not use the, and instead, use geometry.

In the video, see what happens to datum A when you turn off datums. Same as when you hide hide datum A; it doesn't hide. then at some point when you use the datum tag in a drawing, the plane itself hides in the model never to be seen again.

In all, not having layer control or lack of enabling the show/hide datum button makes for a really messy assembly when you are doing screencaps or just modeling. This was always a serious annoyance in the old Pro/E days too.

the method I brought forth in the video is quite stable from what I could tell.

Re: Datum planes in a hidden layer will not hide in the model!

The forum has a bad habit of loosing things...

Video Link : 3961

Re: Datum planes in a hidden layer will not hide in the model!

I re-uploaded the video above, Brent.

Re: Datum planes in a hidden layer will not hide in the model!

Hi guys...

I have a simple solution. I was able to duplicate the problem and I see what you mean about the datums not hiding on a layer properly. However, I have a fix that works and does not require using "On Geometry" or turning the datum into an Annotation Feature.

If you truly don't care to see or use the model-based datums but only intend to view them in the drawing, then set your datums using the old style datum format. See below...

old_style_Datums2.png

Your datums look like this in the model:

old_style_datums1.png

But they look like this in the drawing:

old_style_datums3.png

Best of all, they behave in the model they way you'd expect. They hide themselves on layers and yet show up just fine on a drawing. True, this is a workaround of sorts and if you need to see that new style datum in your model, you're stuck having to disable/enable the display of your datums using the Annotation Display toggle switch. But if you do NOT need to see them in the model... using the old style "set datum" propertiy fixes the problem.

Thanks!

-Brian

Re: Datum planes in a hidden layer will not hide in the model!

I had to log out and log back in to see it. It was there... then it disappeared... now it's back!

Re: Datum planes in a hidden layer will not hide in the model!

Now it has a host of new problems. It still doesn't hide the plane with the show/hide datum button although the layer hiding does work. I also could not get a second instance of the datum to display in the drawing where the annotated datum would.

The fact that the annotated datum has specific display control is a plus. I think last time we discussed this we came to the conclusion that having datum planes and axes specifically for the callout was a preferred method of defining the datum tags for drawings or 3D drawings. At the time it was Creo 1.0 and it still had major issues with crashing when you moved datums. I settled for symbols in the drawing over datum tags. I'd be willing to give it another go with Creo 2.0 to see if it has become more stable. But I must have control over display of the datum planes when modeling.

You don't get the option when the tag is attached to a plane or axis, but when applied to a geometry surface, the datum becomes "subordinate" and you get control over its display. This is much preferred unless I am overlooking something.

hide+tag+datum.JPG

Re: Datum planes in a hidden layer will not hide in the model!

I'll have to re-read this in the morning. I'm having trouble digesting any more GTOL stuff tonight.

I'll have to take another run at it tomorrow. If we manage to get together in Anaheim, I can see we'll probably have a whole lot to talk about.