cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Fatal Error encountered while working in Creo 5.0 Parametric

SOLVED
Highlighted
Regular Member

Fatal Error encountered while working in Creo 5.0 Parametric

Hi,

     While working on Creo 5.0 Parametric Part modeling Experience Fatal Error warning pops up and the program closes, A Traceback file is generated, Screenshot attached. Please suggest a solution.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric


@Vue412 wrote:

Hi,

      Where can I find the config.pro,  I tried searching in PTC file in C drive there is multiple config.pro files.


Hi,

Creo reads config.pro file located in Creo5_LOADPOINT\Creo 5.0.x.0\Common Files\text directory.

In my installation it is E:\PTC\Creo5_050\Creo 5.0.5.0\Common Files\text\config.pro file.


Martin Hanák

View solution in original post

22 REPLIES 22
Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric


@Vue412 wrote:

Hi,

     While working on Creo 5.0 Parametric Part modeling Experience Fatal Error warning pops up and the program closes, A Traceback file is generated, Screenshot attached. Please suggest a solution.


Hi,

1.] can you reproduce the problem using the same procedure ?

2.] sometimes the problem is related to graphic card drivers

  • open config.pro in Notepad
  • add following option at the end of the file ... graphics win32_gdi
  • test working with Creo

 


Martin Hanák
Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

Hi,

      Where can I find the config.pro,  I tried searching in PTC file in C drive there is multiple config.pro files.

Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric


@Vue412 wrote:

Hi,

      Where can I find the config.pro,  I tried searching in PTC file in C drive there is multiple config.pro files.


Hi,

Creo reads config.pro file located in Creo5_LOADPOINT\Creo 5.0.x.0\Common Files\text directory.

In my installation it is E:\PTC\Creo5_050\Creo 5.0.5.0\Common Files\text\config.pro file.


Martin Hanák

View solution in original post

Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

Hi,

     Sorry for the Delay  I tried your solution added "graphics win32_gdi" in the config.pro file, Now it working fine, Thank for your Support.

Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric


@Vue412 wrote:

Hi,

     Sorry for the Delay  I tried your solution added "graphics win32_gdi" in the config.pro file, Now it working fine, Thank for your Support.


Hi,

the result of your test means that the problem is related to graphic card drivers.

What graphic card is installed in your computer ?


Martin Hanák
Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

AMD Radeon Graphics
Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric


@Vue412 wrote:
AMD Radeon Graphics

Hi,

AMD Radeon Graphics is generic name, could you find exact card type ?

What driver version is installed ? What is release date of drivers ?


Martin Hanák
Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

Hi..

I faced same fatal error and I added graphics win32_gdi  this option.

But it changing the model colour. Model looks dark.

What Should I do?

Tags (1)
Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

The setting graphics win32_gdi  is to help troubleshoot problems with your system.

If the problem is solved with this setting, that means you have a video card problem.

Remove the setting and try updating your graphics card driver. You may need to try several drivers to find one that works without problems.

If you can't find a driver that fixes the problem, you can continue using the graphics win32_gdi   setting but it does have an impact on your computer performance.

Another option would be to upgrade your video card in your computer.

 


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)
Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

Hi,

I have got the same problem. But adding graphics win32_gdi into config.pro didn't solve the problem.

What should I do?

 

Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

Maybe @Mahesh_Sharma  can read your traceback file.

Just to be clear, when you add the graphics option to your config, you have to restart Creo.

Is this happening every time you use creo or just on one part/assy?


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)
Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

Thank you for your fast response. It happend when I want to open bigger assembly (more than 10 parts) or when I want to assemble bigger assembly. If I open assembly with few parts, everything works well.

Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

Also try the config.pro options Mahesh suggested and remove the graphics option (win32gdi) completely

enable_opengl_shader no 

enable_opengl_fbo no

enable_opengl_vbo no

 

After you add them, make sure you start creo again. None of these options do anything unless creo is restarted.

 

If that doesn't work, what are your system specifications? (ram, processor, video card, etc)


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)
Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

I tried everything what I found on this page, but nothings works. I have been using Creo for one year. After one year a licence expired. I tried to renew a licence, but it didn't work. So, I reinstalled creo and add new licence with new licence key. After that started the problem with opening bigger assembly.

Before my licence expired, I could open assembly with more than 1000 parts, so I don't think that problem is in hardware. Now I can´t open assembly with more than 10 parts, although I have got full academic licence without restrictions.

Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

Sometimes a video card driver update helps. Occasionally a windows update will cause issues that a new video card driver will fix. Video card issues are responsible for MANY creo issues, not just display issues.

If that doesn't help, try uninstall - reinstall of Creo, since it seemed the problem showed up on the new installation. 

You are on an older version of Creo, maybe you can download and upgrade to Creo 7. 

I'm pretty much out of options.

 

 


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)
Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

ALSO, since you are using the academic version, you might be able to get tech support by posting in the education forum.

Link:

https://community.ptc.com/t5/PTC-Academic-Program-Discussions/bd-p/PTCAcademicProgram

 


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)
Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

@Vue412 

Can you share generated traceback file to review?

Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

@Mahesh_Sharma, Please find the attached traceback file

Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

@Vue412 

There are some threads about graphics ... 

Try adding below config options .. 

enable_opengl_shader no 

enable_opengl_fbo no

enable_opengl_vbo no

 

Also update the Creo 5.0 datecode to latest available one. 

Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

Hi,

     I Tried to change enable_opengl_shader  to no, but when I clicked OK again fatal Error started popping up and the program got closed 

Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

@Vue412 

Can you share the steps triggering the fetal error?

Highlighted

Re: Fatal Error encountered while working in Creo 5.0 Parametric

Fatal Error occurs due to the below following 2 instance,

1) While working on part modeling first I experience hanging issues while selecting planes for sketching then after doing extruding feature, when I toggle the display model edge (Highlighted in the attached screenshot) the error occurs.

2) While adding trying to add the config options enable_opengl_shader no and click on OK, the error occurs.

 

Announcements