cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Hide Hole Notes on Models (model note display)

SOLVED
Visitor

Hide Hole Notes on Models (model note display)

Hello. We are currently migrating from Creo 2 to 4. As the title says, we need to hide hole notes from the model display. When using Creo 2, we had a configuration called model_note_display but looks like this configuration was deleted since Creo 3. We are wondering if any other configuration replaced that function.

We know we have the display_annotations config, but that would also hide other stuff we need like geometric tolerances or dimensions on the models. Another solution could be hiding the layer where the hole notes are, but we don't have access to modify the start files, not all the models have the same layer structure and we would need to do it on every model we open (at least for the first time).

 

Regards

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Hide Hole Notes on Models (model note display)

There is no config option for hiding the notes, nor is there a config option to not create them in the first place.

 

You can check out https://www.ptc.com/en/support/article?n=CS250479 "How to create Rule to place all hole note into a layer in Creo Parametric".

 

Regards,

 

Dan N.

5 REPLIES 5

Re: Hide Hole Notes on Models (model note display)

There is no config option for hiding the notes, nor is there a config option to not create them in the first place.

 

You can check out https://www.ptc.com/en/support/article?n=CS250479 "How to create Rule to place all hole note into a layer in Creo Parametric".

 

Regards,

 

Dan N.

Re: Hide Hole Notes on Models (model note display)

Thanks for the reply. I couldn't watch the article since I'm using a personal account and don't have access to the customer number to access it with a company account. Still, I already worked it out to add the hole notes to a layer, the only issue I have with my method is that it will work ok with new parts, but for parts created in previous releases, I would need to search in which layers are the hole notes placed and then hide them.

Re: Hide Hole Notes on Models (model note display)

There was a hidden configuration option called "model_note_display" in Creo Parametric 3.0.  This was removed in later versions and replaced with something else (see below.)  Fundamentally it wasn't hiding hole notes, it was actually hiding ALL model annotations, including hole notes.  Annotation display is now controlled differently, but there still isn't an out-of-the-box (backward compatible) way to only turn off display of just hole notes.

 

From CS22006:

  • This option available only until Pro/ENGINEER Wildfire 3.0 release
  • After Wildfire 3.0, option obsolete and users are advised to NOT use option
  • Starting in Wildfire 4.0, use Annotation Element Display icon in the toolbar or follow menu picks below
    • Pro/ENGINEER Wildfire 4.0 and Creo Elements/Pro 5.0:
      • View > Display Settings > Datum Display > 3D Annotations
    • Creo Parametric:
      • File > Options > Entity Display > Show annotations and Annotation Elements
    • config.pro option display_annotations may be used

Re: Hide Hole Notes on Models (model note display)

Thanks for the reply. As mentioned in the second paragraph, we are currently aware of display_annotations. The issue with that config is, as you said, that it hides ALL annotations, that include geometric tolerances and dimensions on the models.

Re: Hide Hole Notes on Models (model note display)

As another option, you can move the note annotations to their own layer and just blank that layer.

 

We use a mapkey and a saved query to put all the hole note annotations on their own layer.  See the attached query file for finding all the hole note annotations.

 

We also created mapkeys to just turn the note annotation display on/off.  It's convenient for turning them off when you cannot modify a released model that still shows the hole note annotations.

 

Regards,

 

Dan N.