cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with keeping instance parameters updated

Visitor

Issue with keeping instance parameters updated

Question for Creo 4 users: I'm creating a sheetmetal part with several instances, each with their own overall length and width parameters based on the flat pattern. The overall length changes from instance to instance. I can get each instance to properly show length and width after regenerating it, but checking the part into windchill and back out often resets the length and width parameters back to the generic's. This doesn't affect the model, but it does affect what I'm trying to show on its drawing. 

 

Any ideas on what's going on here?

2 REPLIES 2
Highlighted

Re: Issue with keeping instance parameters updated

I assume that you are working with a nested family table, where each instance has its own flat pattern.

 

Can you upload the file?

Re: Issue with keeping instance parameters updated

I couldn't get the file to upload for some reason, but here are screenshots of how the table is set up.

 

The flat patterns are just separate instances with the same driving dimensions. As you can see, the regular instances are falling back to whatever the generic's length and width values are. If I go and set them to be flat and regenerate them, they will follow the correct values.

 

I know that it's trying to reference a value that's in a suppressed feature, so I'd expect I'd need to regenerate once to set the values. Why does Creo "forget" these values, though? They eventually just revert to whatever is in the generic. Is there a clever way to get around this?

 

Announcements
LiveWorx Call For Papers Happening Now!