cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Summary: Unit Driven Parameters

Highlighted
Topaz II

Summary: Unit Driven Parameters

OK, I got it to work.  Turns out I was doing all the right things, except for one.  The following applies to WF4.  I assume it carries over to later versions.


  1.  Make sure 'relations_units_sensitive' is set to 'yes'.  Yes is the default, so unless you've set it to no deliberately, you're likely OK.
  2.  Open the relations dialog and expand the parameters area at the bottom.  This gives you access to both at once.
  3.  In the 'Utilities' menu, make sure 'Units Sensitive' is checked.  That was my problem; evidently you can manually turn this off on a per part basis.
  4.  Create the parameter you need, say VOLUME_IN from my example below.  You need to create it rather than simply entering a relation that will force Pro/E to create it because Pro/E won't let you assign units to a parameter driven by a relation.  In fact, if you drive a parameter by a mass properties parameter with 'Units Sensitive' turned on, it seems that Pro/E will assign the units of that M/P parameter to the new parameter.
  5.  Right click on the new parameter and pick 'Insert Unit' or look for the 'Unit' column to the right.  Pick the units that you want your parameter to use, in my case in^3.
  6.  Add your relations, in my example below use this: VOLUME_IN = MP_VOLUME (The (") that I had isn't needed anymore).
  7.  Close the relations dialog.
  8.  Regenerate your part.

If you open the part you should now see the parameter is updated based on the units you assigned, the parts units and the appropriate conversion factor.  If you change your part's units, the value of the new parameter should stay the same.

One caveat - I had the 'unit Sensitive' setting in the relations dialog get lost at one point, however when I attempted to reproduce it I could not.  I thought it was because I created a parameter and set it equal to one with incompatible units (Pro/E will give you an error), but doing it again did not cause the setting to go away.  I haven't seen it again, so I'm not sure how it got unchecked.  It was likely user error. :-S

Thanks,

--
--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
3 REPLIES 3
Highlighted

Summary: Unit Driven Parameters

One thing I forgot, that may be obvious.  You either need a M/P analysis feature in your part or to set 'mass_properties_calculate' to 'automatic' or you won't have any M/P information to drive your new parameter, or it won't be up to date.

--
--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
Highlighted

Summary: Unit Driven Parameters

One important bit of additional information I just learned.  If the units of your parameter match the units of your part, by default they are converted when you change your part units.  You can change this in the dialog that pops up when changing the part units.  There's a parameters tab that lists all parameters that match the part's units.  Select 'ignore' and the parameter will keep its current units instead of changing with the part.

[cid:image001.png@01CDEE5B.2BA6D1C0]

--
--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
Highlighted

Re: Summary: Unit Driven Parameters

Thank you Doug for showing the way on this.  I really appreciate all of the valuable tips you've shared over the years.

Announcements