cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Tagged Datum Display Issue

SOLVED
Highlighted
Aquamarine

Tagged Datum Display Issue

All,

 

Has anyone found a way to HIDE tagged datum planes? According to PTC CS152797, it is working to software specifications. The Tech Support person said this was introduced for MBD files using combination states. I bet only around 10% if that of their customer base is completely on MBD.

 

For those that are still using legacy files, non-MBD, it has completely messed up the layer functionality and causing extra non-layer related steps that CANNOT be automated.

 

For those that have not seen the issue.

  1. Add a datum plane, change the properties, rename it, select Set Datum Tag in the Display section, select On Datum in the Placement section, and select the newly created datum plane.
  2. Hide the layer that the new datum plane resides. Datum is still visible
  3. To turn off: You HAVE to select Annotate tab, right mouse button on newly created datum in the Detail Tree, and select Erase
  4. To turn on: You HAVE to select Annotate tab, right mouse button on newly created datum in the Detail Tree, and select Unerase

 

Layers no longer control the visibility of GTOL Datums.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Tagged Datum Display Issue

You can get layers to control the visibility of the tagged datum planes, but only if your datum tag style is that old-fashioned box and two dashes around the datum symbol.

For the newer style, I'm afraid the "correct" (ahem, PTC approved) method is to use combination states and the tools under the Annotate tab.

I'm still confused as to what is the point of having the functionality to "erasing" annotation elements instead of simply removing them from a combined state.

In our start-parts, we have a combined state called "Annotated" defined and users are instructed to change to it when placing their GD&T information such as set datum tags.  This way they will only show up if the "Annotated" state is activated, and by default, they will stay hidden (because they will not be added to the inactive "Default All" state).

If you are working with legacy data, then it's more painful because as you noticed there isn't much "automation" available when working with combination states.


Also, if you change to "On Geometry" placement for the datum tag, then the option of "Displaying Datum Graphics" becomes available in the edit properties of the datum plane dialog-box.  Now at least you can hide the plane; but the indelible tag remains...  The only thing that works for that is the global "Annotation Display" toggle switch.  It's just mind-boggling, and then there is a whole other layer of confusion when it comes to showing these things on a drawing .

View solution in original post

4 REPLIES 4

Re: Tagged Datum Display Issue

It is very unfortunate that it does work to specifications.  The only workaround I found to date is to bypass GD&T all together.  Another workaround I considered and should help is to define a plane for the express purposes of using it for Datum Tags.  For some reason, if you don't tag the primary planes, you have more control over them.  Also know that some tags disappear (for good!) when they are shown on a drawing face.

I went through a couple of support cases on this and in the end, I decided that Creo's GD&T functionality was just to clumsy and unreliable (as in hard crashes on moving datum tags!) to invest any further effort in.  To date, I still don't miss it.  I have a catch-all datum tag that I drop around my drawing like glitter.

And nobody in my high tech industry gives a hoot about paperless ASME Y14.41 either.  They only quote to paper!

Re: Tagged Datum Display Issue

You can get layers to control the visibility of the tagged datum planes, but only if your datum tag style is that old-fashioned box and two dashes around the datum symbol.

For the newer style, I'm afraid the "correct" (ahem, PTC approved) method is to use combination states and the tools under the Annotate tab.

I'm still confused as to what is the point of having the functionality to "erasing" annotation elements instead of simply removing them from a combined state.

In our start-parts, we have a combined state called "Annotated" defined and users are instructed to change to it when placing their GD&T information such as set datum tags.  This way they will only show up if the "Annotated" state is activated, and by default, they will stay hidden (because they will not be added to the inactive "Default All" state).

If you are working with legacy data, then it's more painful because as you noticed there isn't much "automation" available when working with combination states.


Also, if you change to "On Geometry" placement for the datum tag, then the option of "Displaying Datum Graphics" becomes available in the edit properties of the datum plane dialog-box.  Now at least you can hide the plane; but the indelible tag remains...  The only thing that works for that is the global "Annotation Display" toggle switch.  It's just mind-boggling, and then there is a whole other layer of confusion when it comes to showing these things on a drawing .

View solution in original post

Re: Tagged Datum Display Issue

There is still a way to control set datums using layers, BUT it takes config settings and a little training. (Anything that is already built with the annotation datum set will still not be able to be control by layer)

Datum Plane Tag Display

Config option:

Old_style_set_datum YES

This is the default setting so if you don't have it, you are able to use the "SET" instead of "SET DATUM TAG ANNOTATION".

Drawing setup file:

GTOL_DATUMS  STD _ASME

If you are using the 1994 ASME Y14.5 or later, you will get the new datum style (with the triangle attachment) even if you set it as an old style datum in the model.

It works great and keeps the layer control of the datums available.


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)

Re: Tagged Datum Display Issue

Removing the annotation element from the state keeps the annotation from showing. To get the annotations to show you need to use Show Annotations. Using erase you temporarily show or hide the annotation.

Announcements
LiveWorx Call For Papers Happening Now!