cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

User Defined Parameters?

Newbie

User Defined Parameters?

What is the procedure for loading in a standard set of user-defined parameters into a part?

 

I've tried Tools>Parameters and then create the user defined parameters

Next: File>Save Configuration As:rp_config.xml

Next: Open New Part>Tools>Parameters>File>Load Configuration:rp_config.xml

 

The User Defined Parameters do not show up in the list,...just the Default Parameters?

2 REPLIES 2

Re: User Defined Parameters?

Hi Jolene,

Take a look at the following article for further information on how to copy/export parameters from one part and import to another part:

CS54195 - How to copy/export parameters from one part and import to another part in Pro/ENGINEER and...

If you are not able to access the article, please create a user account here.  The short answer is to copy & paste them.  The long answer is below:

  • Pro/ENGINEER Wildfire 5.0, Creo Elements/Pro 5.0 and Creo Parametric 1.0 - 3.0:
    • Use standard copy paste functionality
  1. Select desired parameter(s) from source model
  2. Edit > Copy or Ctrl-C to Copy
  3. Go to the target model's parameter dialog box
  4. Edit > Paste or Ctrl-V to Paste
  • While copying the parameters or parameter definitions, user can copy:
    • Multiple parameter definitions at the same time, select multiple parameters by using Ctrl or Shift
    • The user-defined parameters and user-locked parameters but not system parameters
    • Parameters from a restricted parameter table
    • Only the value of the parameters definition but not the relation argument while copying a relation-driven parameter
    • Parameters from different context, such as a feature parameter and a model parameter at the same time if viewing multiple parameters.
  • Note: If the same parameter exist in the destination part whose value is read only, Edit > Paste option will not be available for pasting the copied parameters.

Thanks,

Amit

Re: User Defined Parameters?

Hi jkmett,

 

I had the same problem as you, but I was able to solve this by importing/exporting data as a .xml file instead of loading/saving the configuration. This is also in the file dropdown in the parameters window.

 

Best,

Ben