cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Very Strange Missing Reference Error

SOLVED
Highlighted
Regular Member

Very Strange Missing Reference Error

I'm working on a very large assembly in Creo 5, which is some legacy hardware created by a group that no longer exists. I don't know what version the assembly was created in, but it was done in 2000. I had numerous errors upon opening the assembly, all of which I was able to solve except this last one.

There is a part that was apparently used as a skeleton. It is full of surface ids, created off of surface sets. The problem is, the feature which has failed has a missing reference of a surface set. But since there are no surfaces to redefine the feature to, I can't fix the missing reference. It won't allow me to use a datum plane either. I can't delete the feature, because half the items in the top-level assembly fail.

At a loss for how to solve this. Hoping someone has a trick up their sleeve. Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Very Strange Missing Reference Error

@nsgoldberg 

As it is clear that issue s due to missing references and there are no much options available, you may try converting the surface to an independent geometry by Collapse tool, I hope it will not affect other features. 

Steps will be as: 

> Select the surface ID feature in model tree > Editing > Collapse > Range of features > Ok

 

But make sure that you try this on backup data, not on production data. Also make sure this is not making any unwanted changes in your design as this tool break the dependency permanently which cannot revert back... 

View solution in original post

2 REPLIES 2
Highlighted

Re: Very Strange Missing Reference Error

@nsgoldberg 

As it is clear that issue s due to missing references and there are no much options available, you may try converting the surface to an independent geometry by Collapse tool, I hope it will not affect other features. 

Steps will be as: 

> Select the surface ID feature in model tree > Editing > Collapse > Range of features > Ok

 

But make sure that you try this on backup data, not on production data. Also make sure this is not making any unwanted changes in your design as this tool break the dependency permanently which cannot revert back... 

View solution in original post

Highlighted

Re: Very Strange Missing Reference Error

Sorry it took so long to respond, got caught up on another project. This worked! Thank you!

Announcements