cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Volume & Mass

Newbie

Volume & Mass

Proe Users,

We are creating drawings in Creo Elements Pro from older drawing templates and the Volume and Mass won't display on the drawing notes.
These are entered into the notes on the drawing as {0:&PRO_MP_VOLUME} and {0:&PRO_MP_MASS} but nothing is displayed in the note. There are no parameters added to the part and when we try to enter PRO_MP_VOLUME or PRO_MP_MASS as a parameter we are told they are reserved. Can someone please share with me ho w to resolve this issue.

Thank you


Ryan Crisp | Senior Mechanical Engineer

Priority Designs
501 Morrison Rd.
Columbus, OH 43230
(614) 337-9979
www.prioritydesigns.com
3 REPLIES 3

RE: Volume & Mass

Hi Ryan,



I think if you get rid of the extra text surrounding the parameter, your values will show up.



{0:&PRO_MP_VOLUME} should be &PRO_MP_VOLUME


{0:&PRO_MP_MASS} should be &PRO_MP_MASS



I'm not sure why the extra text gets put in, but this happens to me now and again.



Brian

In Reply to Ryan Crisp:


Proe Users,

We are creating drawings in Creo Elements Pro from older drawing templates and the Volume and Mass won't display on the drawing notes.
These are entered into the notes on the drawing as {0:&PRO_MP_VOLUME} and {0:&PRO_MP_MASS} but nothing is displayed in the note. There are no parameters added to the part and when we try to enter PRO_MP_VOLUME or PRO_MP_MASS as a parameter we are told they are reserved. Can someone please share with me ho w to resolve this issue.

Thank you


Ryan Crisp | Senior Mechanical Engineer

Priority Designs
501 Morrison Rd.
Columbus, OH 43230
(614) 337-9979
www.prioritydesigns.comhttp://www.prioritydesigns.com

Highlighted

Re: RE: Volume & Mass

Hello all,

I think we are facing to a similar issue here. I think, the problem it isn't the notes in the drawing because if you load again the format used by the template normally you will see appear the values.

When I create a drawing based on a template, the pro_mp_mass isn't calculted or displayed.

The template (drw) calls a format (frm). Just loading again the format, remove all tables, the pro_mp_mass is calculated and displayed on the drawing.

I don't know why but without this action it isn't possible.

My main goal is to use a symbol allowing the users to change the decimal of the pro_mp_mass. I created the symbol and it works fine.

Screen Shot 02-05-16 at 06.08 PM.JPG

The only problem I have to solve, like you, is during the drawing creation. I want and I need that the symbol managing the pro_mp_mass appears without to have to load again the format.

Stéphane

Re: Volume & Mass

‌Braces with a number and a collon are used for style formatting. If I remember correctly to get a parameter to update when creating a drawing from a drawing template or format the parameter has to be in a table cell, if it's in a note it gets converted to plain text because the parameter doesn't exist. Since it's plain text it doesn't update and you need to remove it and re-add the parameter. To get parameters to update automatically in a note you need to insert notes from a note file after the drawing has been created and a part or assembly is associated to the drawing otherwise the parameter is converted to plain text. Also make sure you have calculated the mass properties using the model properties dialog box.