cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Changing the mass units of a harness part

SOLVED
Regular Member

Changing the mass units of a harness part

Hi, everyone. I'm having an issue with getting a proper mass of my harness parts. Rather, the mass is right but the unit is wrong. I used the Creo mmns template file for my harnesses and now they report mass in tonnes. I want to change the mass units reported with the PRO_MP_MASS parameter, but since I cannot open a harness part by itself, I find no way of getting into the model properties to be able to change it. Does anyone have a workaround for this?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Changing the mass units of a harness part

Hi,

I hope I found a solution ... see attached CS155622.pdf.

---

1.] activate Cabling assembly

2.] click File > Prepare > Model Properties, then change in Units row

3.] set a System of Units and tick the "Include Submodels" box to propagate to harness

include.png

4.] regenerate assembly

result.png


Martin Hanák
6 REPLIES 6

Re: Changing the mass units of a harness part

Hi,

can you upload your harness part ?


Martin Hanák

Re: Changing the mass units of a harness part

Hi, Martin.

 

I could, but I don't see how that would help. Anyone can recreate the issue this way:

 

  1. Start an assembly.
  2. Launch the Cabling module.
  3. Create a new harness part.

Having done the above steps, how is it possible for me to change the units in the harness part? I can change the length units through the Setup command, but this doesn't allow me to change the mass units. I can create a new harness part with different units by using a different template part, but is it possible for me to change the mass units for the existing one?

Re: Changing the mass units of a harness part

Hi,

just a simple note ... you are asking for a help ... if you provide testing data, then you will probably receive quick answer Smiley Happy


Martin Hanák

Re: Changing the mass units of a harness part

Hi again.

 

Sorry, didn't mean to seem ungrateful. I've uploaded a zipped cabling assembly. The assembly and connectors are all in mmks, whereas the harness is in mmNs. Basically, the assembly was created as mmNs, but then changed to mmks. Now I want to change the harness part, as well. The reason for this is that the PRO_MP_MASS parameter of the harness part reports in tonnes, rather than kg. If you look at the screenshot below, you can see that the mass parameter of the harness part is significantly lower than the connector parts. I'm using Creo 3. Very thankful for any assistance!

 

(This is not my original assembly, which I cannot share since it belongs to a customer, but it's the same issue, except for that assembly having several harness parts, and redoing it from scratch isn't an option.)

 

Capture.PNG

Re: Changing the mass units of a harness part

Hi,

I hope I found a solution ... see attached CS155622.pdf.

---

1.] activate Cabling assembly

2.] click File > Prepare > Model Properties, then change in Units row

3.] set a System of Units and tick the "Include Submodels" box to propagate to harness

include.png

4.] regenerate assembly

result.png


Martin Hanák

Re: Changing the mass units of a harness part

I can't believe I missed this obvious solution. I never noticed that checkbox before. Thank you so much for your help.