cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

WGM - ECAD Check in - Problem while creating BOM

Highlighted
Newbie

WGM - ECAD Check in - Problem while creating BOM

Hi everyone,

It seems that some people here know a little thing about WGM, that's great because I need help !

Actually the situation is not complicated but I don't get it why it isn't working for me

What I did :

I created a BOM Map file which links the Windchill attributes and Product attributes. I also created a combined Platine and Schematic Files wich will store my *.pcb und *.sch files. The BOM Map file is set for both of these files.

What is working :

I can make the ECAD-Check-in without creating BOM. At the End I have my PCB and SCH Files in WGM with the respective .zip file and  Visualisation. It's really nice.

What isn't working :

When I try to create a BOM during the ECAD-Check-in process here come the problem.

     1) I want to create a BOM (stückliste) for the PCB (green) for instance

                                 2) I see the BOM-report with Parts in/out Windchill

     3) I choose the Assembly And/or Platine (tried both, not working either)

                                                                     4) Everything is fine, let's just checkin everything as usual                        

                                 

        

5) The Checkin doesn't work. It says that the Argument 3 is empty and that I should change this and try again after. But what is this Argument 3 ?? I received this message everytime I want to create a BOM while Check In. Worst Part is that I can't check-in after that even without creating a BOM (I always receive thie error). The problem arrives the first time I want to create a BOM and don't go away after..

I tried with other files (pcb and Sch) but I always have this failer, I just can't generate BOM File during the ECAD-Checkin.

Thanks a lot for any Help, I am trying to contact PTC but got no answer so far.

Best Regards

Aym

1 REPLY 1

Re: WGM - ECAD Check in - Problem while creating BOM

It looks like you are on 10.2.

I think to get the BOM to build correctly in 10.2 you need to have a WT Part that you set as the board (Platine).  In theory, you should have one WT Part for the PCB Assembly, to which the bare PCB board and all the components get assembled to.  If you go and create a WT Part for your bare PCB and associate the PCB file that you have to it, then you should be able to search for the board part and attach that (should be third from left button). 

The icons are confusing, because it looks like it should be searching for the CAD Doc of the PCB, but it's actually searching for the WT Part of the PCB.