cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

License request failed for feature PROE_ProcessModeler: -5:

SOLVED
Highlighted
Newbie

License request failed for feature PROE_ProcessModeler: -5:

I have everything set up properly, and there are licenses available to use, and Pro/E can obviously contact the server and can see the licenses, and I am able to log on to intralink. Anyone have any clues? windows 7 64bit, 12gb ram, xeon processor.

(I've taken out everything it listed other than what it is displaying to protect the company.)

1 ACCEPTED SOLUTION

Accepted Solutions

Re: License request failed for feature PROE_ProcessModeler: -5:

John,

go to PROE\bin directory and find PSF file (.psf extension), which correspond with your startup command. By default, its name is proe1.psf. In my installation its name is proeWildfire4_M150.psf (below you can find the contents of my proeWildfire4_M150.psf).

// PTC - PSF file: proe

//

PRODUCT=Pro/ENGINEER

DESC=proeWildfire4_M150

ENV=INTRALINK_DIR=

ENV=ILINK_CMD_NAME=

ENV=INTRALINK_CMD=%INTRALINK_DIR%\bin\%ILINK_CMD_NAME%

ENV=MECH_LP=__MECH_LP__

ENV=MECH_HOME=%MECH_LP%\%PRO_MACHINE_TYPE%

PSF=%MECH_LP%\install\nt\mech.psf

ENV=PRO_MECH_COMMAND="%PRO_DIRECTORY%\bin\proe.exe" "%PRO_DIRECTORY%\bin\proeWildfire4_M150.psf"

ENV=PATH+=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\deflib

ENV=PATH-=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\lib

ENV=PATH-=%INTRALINK_DIR%\%PRO_MACHINE_TYPE%\illib

ENV=PTCNMSPORT=1239

ENV=NMSD_TIMEOUT=300

ENV=PRO_COMM_MSG_EXE=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\pro_comm_msg.exe

ENV=PROE_START=%PRO_DIRECTORY%\bin\proe.exe

ENV=CDRS_DATA=%PRO_DIRECTORY%

ENV=PRO_IMAGE_CONVERTER=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\convert_image.exe

ENV=GALAXYHOME=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%

ENV=PROGUIDE_DIRECTORY=%PRO_DIRECTORY%\uifdoc

ENV=SPG_DIRECTORY=%PRO_DIRECTORY%

ENV=PRO_USRMAIN=%PRO_DIRECTORY%\usrprog\umain\usrmain.c

ENV=PROTABLE_DIRECTORY=%PRO_DIRECTORY%\protable

ENV=PROTAB=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\protab.exe

ENV=ZIP_EXEC=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\zip.exe

ENV=CLHOME=%PRO_DIRECTORY%\text\pcldata

ENV=PVIEW_PROEPVIEW_HOME=%PRO_DIRECTORY%\apps\prodview

ENV=CV_ENV_HOME=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\CV102

ENV=VC_VCONF_START=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\ptcvconf.exe

ENV=DEBUG_HLP_DLL_PATH=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\lib\dbghelp.dll

ENV=PTC_D_LICENSE_FILE-=7788@bravemh

ENV=PROE_FEATURE_NAME=PROE_FoundationAdv ()

RUN="%MECH_LP%\install\nt\pro_mech_env.bat"

RUN="%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\nms\nmsd.exe" -noservice -timeout %NMSD_TIMEOUT% &

RUN="%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\xtop.exe"

// USER - PSF

// Add User specific environment or run applications below here

I highlighted 2 lines. You can edt them inseide notepad.

First one contains the path to license server ... 7788@bravemh.

Second one contains the license name ... PROE_FoundationAdv.

Martin Hanak


Martin Hanák
14 REPLIES 14

Re: License request failed for feature PROE_ProcessModeler: -5:

Hello!

Run the file "ptcstatus.bat" from the folder "C:\Flexlm\bin". Check the debug log file "ptclmgrd.log" (this log is intended for debug purposes only), which is located in the folder: "C:\Flexlm\licensing". If you have an active (paid) maintenance, then try to create a new "Case" with a description of the problem here: http://www.ptc.com/appserver/cs/case/case_logger.jsp

P.S. You forgot to mention what Pro/E version you using?

Re: License request failed for feature PROE_ProcessModeler: -5:

Wildfire 4.0

I tried the Ptcstatus.bat, but it just displayed exactly what the error message said when I open Pro/e, a list of all the available licenses (which there are alllot, no single license is unavailable )

as for the log, I can not find the file anywhere.

To my supprise my company does not pay for the maintenance for it any more..... considering the massive time and effort being put in to the WF4 installs on win7 machines they would pay for it because thic stuff would be resolved in a snap. All the IT guys here han't a clue what to do from here and the one person that is experienced with doing the.... 'custom' installs of wf4 on win 7 machines, is out sick, has been for a little while, so must be bad. So I'm doing my best to get it running without them.

Re: License request failed for feature PROE_ProcessModeler: -5:

John,

according to FLEXNET guide, the return code -5 means, that "No such feature exists." If I were you I would check the following:

  1. The content of license file. It must contain the line ... INCREMENT PROE_ProcessModeler ptc_d 29.0 permanent 1 \
  2. The lmgrd.exe and ptc_d.exe processes on license server. Both processes must be running.
  3. ptcstatus.bat output on license server. The output must contain PROE_ProcessModeler line.
  4. ProE startup command configuration on your workstation. Command must point to correct license server and correct license name. Try to turn off firewall on license server, too.

Martin Hanak


Martin Hanák

Re: License request failed for feature PROE_ProcessModeler: -5:

John O\'Brien wrote:

...as for the log, I can not find the file anywhere...

Look at "Config Services" tab. What path there are specified (if necessary, specify the path to the log file/create an empty text file for the log [with ".log" file extension])?

Re: License request failed for feature PROE_ProcessModeler: -5:

How do I access that application? the server info was set up in the batch install and is configured properly because i can see everyone and every single license that is in use and available, Process modeler is among the list of available licenses.

Re: License request failed for feature PROE_ProcessModeler: -5:

How do I change which license that the ProE startup command points to? I thought that if i changed that to another license it might work, but have no clue where/what code or command batch file to edit.

Re: License request failed for feature PROE_ProcessModeler: -5:

John,

go to PROE\bin directory and find PSF file (.psf extension), which correspond with your startup command. By default, its name is proe1.psf. In my installation its name is proeWildfire4_M150.psf (below you can find the contents of my proeWildfire4_M150.psf).

// PTC - PSF file: proe

//

PRODUCT=Pro/ENGINEER

DESC=proeWildfire4_M150

ENV=INTRALINK_DIR=

ENV=ILINK_CMD_NAME=

ENV=INTRALINK_CMD=%INTRALINK_DIR%\bin\%ILINK_CMD_NAME%

ENV=MECH_LP=__MECH_LP__

ENV=MECH_HOME=%MECH_LP%\%PRO_MACHINE_TYPE%

PSF=%MECH_LP%\install\nt\mech.psf

ENV=PRO_MECH_COMMAND="%PRO_DIRECTORY%\bin\proe.exe" "%PRO_DIRECTORY%\bin\proeWildfire4_M150.psf"

ENV=PATH+=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\deflib

ENV=PATH-=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\lib

ENV=PATH-=%INTRALINK_DIR%\%PRO_MACHINE_TYPE%\illib

ENV=PTCNMSPORT=1239

ENV=NMSD_TIMEOUT=300

ENV=PRO_COMM_MSG_EXE=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\pro_comm_msg.exe

ENV=PROE_START=%PRO_DIRECTORY%\bin\proe.exe

ENV=CDRS_DATA=%PRO_DIRECTORY%

ENV=PRO_IMAGE_CONVERTER=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\convert_image.exe

ENV=GALAXYHOME=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%

ENV=PROGUIDE_DIRECTORY=%PRO_DIRECTORY%\uifdoc

ENV=SPG_DIRECTORY=%PRO_DIRECTORY%

ENV=PRO_USRMAIN=%PRO_DIRECTORY%\usrprog\umain\usrmain.c

ENV=PROTABLE_DIRECTORY=%PRO_DIRECTORY%\protable

ENV=PROTAB=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\protab.exe

ENV=ZIP_EXEC=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\zip.exe

ENV=CLHOME=%PRO_DIRECTORY%\text\pcldata

ENV=PVIEW_PROEPVIEW_HOME=%PRO_DIRECTORY%\apps\prodview

ENV=CV_ENV_HOME=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\CV102

ENV=VC_VCONF_START=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\ptcvconf.exe

ENV=DEBUG_HLP_DLL_PATH=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\lib\dbghelp.dll

ENV=PTC_D_LICENSE_FILE-=7788@bravemh

ENV=PROE_FEATURE_NAME=PROE_FoundationAdv ()

RUN="%MECH_LP%\install\nt\pro_mech_env.bat"

RUN="%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\nms\nmsd.exe" -noservice -timeout %NMSD_TIMEOUT% &

RUN="%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\xtop.exe"

// USER - PSF

// Add User specific environment or run applications below here

I highlighted 2 lines. You can edt them inseide notepad.

First one contains the path to license server ... 7788@bravemh.

Second one contains the license name ... PROE_FoundationAdv.

Martin Hanak


Martin Hanák

Re: License request failed for feature PROE_ProcessModeler: -5:

THANK YOU SOOOO MUCH your a life saver!!!!!!!!!!!!!!!!

When I looked at the license list, the process modeler was available for using, but I saw that most of my office uses foundation av, all i had to do was open that file, tell it to use foundation and NOT processmodeler and BOOM I'm in, so much for "tech support," THANK YOU!

Re: License request failed for feature PROE_ProcessModeler: -5:

You can find "lmtools.exe" in this folder: "C:\Flexlm\i486_nt\obj".