cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

“The contact area is non-zero for zero load” – however there is no initial interference!

SOLVED
Highlighted
Level 8

“The contact area is non-zero for zero load” – however there is no initial interference!

Hello all

 

I remember to have had similar issue in Creo Simulate 2.0 and now I see it also in Simulate 4.0.

It usually happens in large deformation with contact.

 

I have an assembly (very similar to a crank slider mechanism) with parts in contact but not with initial interference. Global interference analysis in the assembly confirms this.

 

There is no imposed initial load/displacement or preload at zero load step. The mesh in the contact areas is not coarse and meshing does not present any warning.

 

Even if “Press fit” is unchecked it still finds an initial contact area!

 

To make thinks more difficult sometimes the same model with slightly different assembly (slider in another position for example) shows indeed no contact at zero load and the simulation goes directly to the next step.

 

The point is that if the simulation presents this characteristic it usually takes considerably more time to finish and is more prone to have convergence problems.

 

Any clue or advice/suggestion here?

 

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: “The contact area is non-zero for zero load” – however there is no initial interference!

Hello!

 

I modified the assembly and finally found a more robust combination of constrains. Now all the “pairs clearance” are showing 0 – in assembly and in Simulate.

The consequence is that the simulation is taking a fraction of time that I had before. I had after 30min the result. Before no sign of improvement after 10h of simulation! Huge progress here!

 

I still have problem to understand this sensitivity to this such small interference value.

 

Complementing your comments, I also don´t like the way as Creo divides the surface of spheres and cylinders.

Few years ago, I put already in the forum that I was having troubles to make the intended mapped mesh exactly due this interface (using Creo 2.0).

I also remember cases that I had simulation problems when an assembly was in a position in between two positions that worked fine – even if the difference was just a couple of mm. The assembled had a sphere in contact.

 

Finally, the “press fit” gap was a reason why some simulations “missed” some contacts. An example was introducing deliberate interference during assembly to simulate preload. I adjusted the preload gap, but I did not modified the “maximum initial interpenetration”. I think I had no preload or something very odd – can´t remember.

I may think that I understand “press fit” but why the same rules do no apply everywhere? If the interference in my trouble assembly is so small, why unchecking “press fit” still creates an initial contact?

 

Anyway, the original problem is solved, and I think we had a very interesting discussion here! Thanks a lot!

4 REPLIES 4

Re: “The contact area is non-zero for zero load” – however there is no initial interference!

Modelling accuracy settings could play a part. I recommend absolute accuracy, the same for assembly and parts and somewhat tighter accuracy might help. (example for my stuff = absolute 0.01mm)

Also, under the Autogem drop down - Geometry Tolerance Settings.  Try absolute settings.

(Example for my stuff = 0.01 absolute for 3 tolerances length, surface,and merge)

The model is "translated" into the simulate model so points can move very slightly.

Also maybe try varying the configuration option sim_contact_penetration. This setting is dependent on mesh size and smaller leads to slower convergence. I set as large as I can where results are not showing intersections larger than I think reasonable. For example 5% (creo default) of a large element might be too much but 5% of a tiny element might be too little. Currently my default is 15 (15%) and adjust down from there when needed.

 

Simulations are tricky with contacts, some models solve better and faster using a small amount of interference at the start, rather than clearance. I try to be either clear with a gap or for sure interfering rather than "touching" because it varies what you get with that.

 

Anyway there are my thoughts.

Re: “The contact area is non-zero for zero load” – however there is no initial interference!

Thanks for the inputs!

 

Modelling accuracy are set to lowest absolute value as well for AutoGem "geometry tolerances settings".

The tolerance report in Simulate shows "tolerance values" 0.012000480019201 for all parts (don´t know how Creo got these values!!!), "absolute" and "accuracy value" of 0.001mm also for all parts. 

 

Now some new things:

_ I started to play with the contacts, isolating one by one until find the one (or more) that are creating this initial non-zero contact.

_ I found that it comes from one of the lever’s pivots (geometrically a cylinder inside a hole). Creo shows no interference but when I go in "Inspect" and run "pairs clearance" it finds “Clearance = 0.0000000000.” in all contact, except on this pivot (Clearance = 0.0000005099.). It is a very small number (set is in mm).

 

About your comment about “translating the CAD model into Simulate”, I never though that this could be the source of some problems.

 

Anyway, inside Simulate I ran again the "pairs clearance" and was Clearance = 0.0000000000 for all contacts except the problematic one. However, the value in Simulate is now “Clearance = 0.0000009769.”

Indeed, the value is different but, in my opinion, still too small to be captured during meshing.

 

The 1st thing is that the assembly is doing something wrong with the input constrains. So, changing the assembly until get all clearances “0” would be a direction. It is possible but nevertheless boring to keep trying – especially if it is a bug.

 

I think I played with the “sim_contact_penetration” a long ago in Creo 2.0. Mostly trying to speed-up the simulation. But I had (and still have) problems to evaluate if the results are ok or not. The easier way is to benchmark results within simulations and with other FEMs.

If I´ll work a lot with the model it is valid to do this study before. Set the option for a higher value may indeed help, but you may not know if there are special situations where the result is very different from the standard 5%.

 

In Simulate 5.0 they are using more options in contact convergence (Unfortunately we just moved to Creo 4.0…).  They moved some controls from the "configuration editor" already to the simulation definition window. This means that playing with the configuration is an "official" tool. I hope that this also comes with a much better help file that we find today for the options.

 

 

Re: “The contact area is non-zero for zero load” – however there is no initial interference!

Thanks for the detailed response!

 

 

The idea that the model is "translated" into the simulate side comes from two things.

It was clear in the old independent mode by inspection that the model was not the same and used a translation.

There is still a setting for tolerance separately on the simulate side. (screenshot below)

 

So I use the term "translated" loosely as I am not sure if the same graphics kernel is used (Granite) in the simulate mesher. My suspicion is that it is not (at least for P-elements side).  The ability to choose new accuracy for edge merges, small surfaces etc has a lot of implications.

 

Also the handling of analytical geometry such as cylinders and spheres seems to oscillate a little between versions. Some Creo versions seem to handle them better than others. I think it has to do with the Creo method of splitting cylinders and spheres into two halves and where/how it splits and the orientation/converged vertex of U-V lines for spheres. These can create trouble areas. Inspect-mesh surface (not element mesh) to check U-V lines. This is an area I think PTC should improve upon.  Maybe I should submit the suggestion to them.

 

I am not sure if this is why you have those troubles but figure this is somewhat useful information to know.

 

If someone has a better explanation of when and when not to use the "press fit" check box it would be useful.  I have not seen a whole lot of difference caused by these settings, but to be fair I have not studied it in depth.

 

regards,

Geomerty Accuracy Settings.PNGCreo Simulate Geometry Tolerance Settings

 

Re: “The contact area is non-zero for zero load” – however there is no initial interference!

Hello!

 

I modified the assembly and finally found a more robust combination of constrains. Now all the “pairs clearance” are showing 0 – in assembly and in Simulate.

The consequence is that the simulation is taking a fraction of time that I had before. I had after 30min the result. Before no sign of improvement after 10h of simulation! Huge progress here!

 

I still have problem to understand this sensitivity to this such small interference value.

 

Complementing your comments, I also don´t like the way as Creo divides the surface of spheres and cylinders.

Few years ago, I put already in the forum that I was having troubles to make the intended mapped mesh exactly due this interface (using Creo 2.0).

I also remember cases that I had simulation problems when an assembly was in a position in between two positions that worked fine – even if the difference was just a couple of mm. The assembled had a sphere in contact.

 

Finally, the “press fit” gap was a reason why some simulations “missed” some contacts. An example was introducing deliberate interference during assembly to simulate preload. I adjusted the preload gap, but I did not modified the “maximum initial interpenetration”. I think I had no preload or something very odd – can´t remember.

I may think that I understand “press fit” but why the same rules do no apply everywhere? If the interference in my trouble assembly is so small, why unchecking “press fit” still creates an initial contact?

 

Anyway, the original problem is solved, and I think we had a very interesting discussion here! Thanks a lot!