cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't Publish since updating to Vuforia Studio 8.3.4

SOLVED
Level 5

Can't Publish since updating to Vuforia Studio 8.3.4

I was on 8.3.1 and it was publishing just fine, I updated to 8.3.4 and the publishing stopped working. I do not get any errors in Vuforia Studio itself, but it doesn't ever show the publishing progress bar, the publish and saves button grey out, and the log shows the following:

[10/09/2018 13:09:18] error: [twx-studio:index] uncaughtException SyntaxError: Unexpected token < in JSON at position 0
[10/09/2018 13:09:18] at JSON.parse (<anonymous>)

 

I have successfully validated the Experience Server and the only change was updating.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Can't Publish since updating to Vuforia Studio 8.3.4

Locate publish.js and change line 37 to the following:

let mtgCapabilityParams = {};//body ? JSON.parse(body) : {};

I had this same problem and the change above fixed it.  The CAD target capability they had on the server was improperly handled.  The server returns something like <anon> which JSON.parse can not handle (and throws an error).

 

5 REPLIES 5

Re: Can't Publish since updating to Vuforia Studio 8.3.4

We are wondering if it is possible that the new version of ThingWorx studio application will not communicate with old version of On-Prem Experience server?  Our plan is to upgrade the ES.

Re: Can't Publish since updating to Vuforia Studio 8.3.4

Locate publish.js and change line 37 to the following:

let mtgCapabilityParams = {};//body ? JSON.parse(body) : {};

I had this same problem and the change above fixed it.  The CAD target capability they had on the server was improperly handled.  The server returns something like <anon> which JSON.parse can not handle (and throws an error).

 

Re: Can't Publish since updating to Vuforia Studio 8.3.4

Hi - 

would you be able to provide some more info about the ES you are/were using? Is it a trial instance, PTC hosted, or on-prem? Which version was it?

We will put in a fix for this, but would like to better understand how it came to occur.

Thanks

Re: Can't Publish since updating to Vuforia Studio 8.3.4

Thanks.  It's on-Prem server for which we are paying subscription on.  (not trial license..however, this ES version represents the version from the On-Prem trial).   Our admin is in process of updating the ES to a new version, so I don't know honestly if it is worth time trying to chase a permanent solution or not if we know the updated version will eliminate this issue. 

 

I can get more details on the exact version of the ES, but if the new version resolves this issue, than I think we can ignore it.  I've already got something in place internally to make sure all our Studio user's get this change.   

Re: Can't Publish since updating to Vuforia Studio 8.3.4

Thanks for the info. I suspect it's the older version of the ES that causes this behavior. I expect we will get the Studio change into the November release