cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creating a sequence

Level 7

Creating a sequence

Hi there,

 

I have two questions. I am relatively new in the use of vuforia studio and now trying to use sequences in my experience. Within the course "Fundamentals of AR Development with Vuforia Studio" (link) there is a pretty good example (5.8-5.11). This one did work for me as well!

 

Now I tried the same way to use my own Model. The Problem is, that I don't know where to get the path for the value. Opening the .pvz file as zip, it only shows the name, not the whole path.

 

Unbenannt.PNG

 

Just for a quick proof, I also tried the easy and short method, explained in the help center (link), since there is no .js use but only drag and drop. The problem is now, that even following this instruction step by step, the preview function only shows the selection (yes, including the sequence names), but it's not possible to play them. Do you have an idea, where the problem is? The click-event is bound correctly to the model, which seems to be the most obvious possibility.

 

Thanks in advance for your help.

 

 

 

8 REPLIES 8

Re: Creating a sequence

Hello,

 

This method is not update now for your use case.

 

We used this method in a first release of Vuforia Studio because .pvi files (Sequences) were not be read inside .pvz file.

It was needed to extract them manually from .pvz file and upload it in Vuforia Studio.

 

Now, we don't recommand this way.

I would recommand approch explains in this help center page :

http://support.ptc.com/help/vuforia/studio/en/#page/Studio_Help_Center%2FTutorialSequenceList.html%2...

 

As you said, a drag and drop is just needed to populate the Select Widget.

 

To play the Sequence, it is needed to have a binding between the Select Widget and the Property in 3D Model.

It is the step 9. 

 

  • Do you have this binding ?
  • Do you a button to start to play Sequence selected ?

 

Best regards,

Samuel

 

 

Re: Creating a sequence

Hi Samuel, 

 

Thank you for the quick response. As you can see in my second link, I did also follow the instructions of the link you just postet (well, in german, but going through, it seems to be the same). So yes, unfortunately I have this binding and a play button, incl. correct binding. Thats why I tried to figure out my mistake.

 

To be sure, I also used a model from the lesson mentioned above (the robot arm model) and it also didn't work out. I also tested the following, to ensure, that it's not the animation, which failed: http://support.ptc.com/help/vuforia/studio/en/#page/Studio_Help_Center%2FIntermediateHandsfreeAnimat... This did work properly. Any ideas?

 

Best Regards

Ferdinand

 

 

Re: Creating a sequence

Hello Ferdinand,

 

  • Is it possible to share your Project ?

         I would like to have a look on my workstation and test it.

         To be honest, I just have one other idea.

  1. In Preview, run Developper Tools (press F12 key)
  2. In Console, do some errors are reported ?

 

Best regards,

Samuel

Re: Creating a sequence

Hello Samuel,

 

I wouldn't share this specific project, due to the model, but I could possibly change the model. As you asked, I just verified: Yes, there is an error reportet:

 

It says:

 

***Model*** failed to load pvi sequence2   (which was the selected one in the select widget)

Unbenannt.PNG

Do you know what can cause this issue? Calling for the sequence without list did work in a prior testing.

Best regards


Ferdinand

Re: Creating a sequence

Hello Ferdinand,

 

In which verion of Creo Illustrate this Sequence has been created ?

Is it a Project in Vuforia Studio for mobile, 3D eyewear (hololens) or 2D eyewear ?

 

Best regards

Re: Creating a sequence

Hi Samuel,

 

It is Creo Illustrate Version 5.0.

Vuforia Studio (On-Premises) Version 8.3.6

Setting: mobile

 

Best Regards

Ferdinand

Re: Creating a sequence

Hello Ferdinand,

 

It seems this issue is specific to the model used.

Creo Illustrate 5.0 is supported with Vuforia Studio and Sequences.

More details here :

https://www.ptc.com/en/support/article?n=CS272270

 

It might be a bug or a problem with the file itself.

 

At first, I will try to upgrade to last version of Vuforia Studio.

Vuforia Studio 8.4.0 is available since yesterday.

https://community.ptc.com/t5/Studio/What-s-New-in-Vuforia-Studio-8-4-0/td-p/594187

 

Best regards,

Samuel

Re: Creating a sequence

Hi Samuel,

 

Thank you for the Support. I would love it to be a problem with the model itself, this could be fixed, but there are two reasons why I can't believe that. 

 

1. I tried the same with the "robot arm model" from the vuforia examples and it did not work either

2. I did test the sequence without select widget (this tutorial: http://support.ptc.com/help/vuforia/studio/en/index.html#page/Studio_Help_Center/IntermediateHandsfr...) and the sequence did work out pretty good

 

The thing what makes the problem hard to find is, that the sequence select did work with the "robot arm model" example of the course, using the given java script code. 

 

Unfortunately I can't update the version all too soon. Our IT is strictely protected and our IT department always needs a certain time before they can renew the version, which means, that we will always be a little behind with updates Smiley Sad I guess in this case, I am limited to living with the situation or finding another workaround.

 

Thank you for your help anyway.

 

Best regards

Ferdinand