cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Live Data is not streaming in the vuforia experience (Raspberry Pi Demo)

Level 4

Live Data is not streaming in the vuforia experience (Raspberry Pi Demo)

Hey ! I'm trying to implement the Raspberry Pi Demo as shown in (https://support.ptc.com/help/vuforia/studio/en/#page/Studio_Help_Center/RPAdvancedIntro.html#)

 

I completed every step as shown in demo but the Temperature and Memory Guage in the vuforia experience is not displaying the live value of the properties. Although It is continually refreshed in the ThingWorx Platform (RaspberryPiThing) but it is not displayed in the experience.  I've attached the screenshot of the preview of the vuforia studio experience. I've followed each step demonstrated in the setup. What am I missing here ?

6 REPLIES 6

Re: Live Data is not streaming in the vuforia experience (Raspberry Pi Demo)

Hi @Vinit31 ,

 

I could not remember this demo in detail, but the first thing what you need to check is if the value will go to thingworx thing property . So you need to check if the live data will change the property value in the RaspberryPiThing

2019-01-31_13-31-19.gif

So here we can first indetify where the issue is caused 

- the probelm could occurs in the remote connection of the thing /appkey , wrong IP etc

- or some permission issue for the Expierence Service setting

Re: Live Data is not streaming in the vuforia experience (Raspberry Pi Demo)

Hey, @RolandRaytchev  Thanks for reaching out. According to you, I should check if the live value is updated in the Thingworx Platform thing (RaspberryPiThing). I already mentioned in my query that it is updating live. The problem seems to be with the Vuforia Experience. I've attached the screenshot of the Thingworx Platform. You'll see the values of the properties of the Thing which get updated every time I hit refresh.

Re: Live Data is not streaming in the vuforia experience (Raspberry Pi Demo)

Hi  @Vinit31 ,

thanks for your feedback. OK some time when I skim over atext I could overlook some details. So that I am sorry if you have to repeat some think. 

So now - could you please, open you preview in debuging mode.

So in preview click Shift-Strg-I keys to go into debugging mode.

 

2019-02-01_11-40-20

1.) so the first thing is to check what is the printing in your console windows. Are there any error message /mostly in red color) where we can see what is going wrong.

2.) second question is what kind if ES (experience service) do you use?

2.1)- on premises server hosted by your /your company 

2.2) - Experience service hosted by PTC cloud - commercial instance 

2.3) - Experience service hosted by PTC cloud - trail instance 

 

Also information about the used version will be helpful

to check it , please,  call in the chrome browser the  URL address of ES + /ExperienceService/properties/version

example:

https://xxxxXx.studio-trial.thingworx.io/ExperienceService/properties/version
e.g. returns: "8.3.8-b773"

For point 2.1)  it means the ES was hosted by you , also installed locally- in this case  we need to check the following setting- here I want to refer the Vuforia Studio Help. You need to check the required step if they are already done for your ES/TWX

 I .)Configure Public Access to ThingWorx

II.) Grant User Permissions    

Because for the PTC cloud server instances these steps are already done when the instance was installed but the cloud team. But for in premises instance this step are additional to the installation.

Re: Live Data is not streaming in the vuforia experience (Raspberry Pi Demo)

Thanks @RolandRaytchev  for replying. I found the issue I was going through the demo instructions page and found the line 

"NOTE: The Composer launched via the Experience Server is not the same as the one launched via the Foundation Server on the Developer Portal."

 

That is what I was doing wrong. I was using ThingWorx Composer from developer portal instead of using it through the experience service URL. I corrected it and now it runs perfectly without any hassle.

 

Thanks for helping me though! Smiley Happy

 

Re: Live Data is not streaming in the vuforia experience (Raspberry Pi Demo)

Hello Vinit,

 

sorry to bother you but I am currently trying to set this up as well using my Trial-Version.

 

In the Tutorial it says to create an Application Key and a Thing manually, but I am not able to do so! I only have permission to read. 

Somehow there was a pre-created Raspberry Pi Thing but in "My Properties" its empty and I cant add anything.

 

Were you able to do edits and so on with a Trial-Version? I assume you are on trial as well.

 

I would be very grateful if you could help me out, I can't find any useful information...

Re: Live Data is not streaming in the vuforia experience (Raspberry Pi Demo)

Never mind, I just found the solution...