cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Model and tracker not lining up with ThingMark

SOLVED
Highlighted
Level 1

Model and tracker not lining up with ThingMark

Hello,

I have the thingMark scaled to 1, and I printed the ThingMark at it's default scale (5cm).

When I start the experience, it anchors the model about 20 feet beyond where I am looking.  When I look directly at it it looks almost correct, but in an Escher sort of way, when I try to walk around it, the Anchor is about 20 feet past the ThingMark.

How do I adjust the HoloLens's perception of the ThingMark's size so that it knows how close it is to me?

Also, I tried to take a picture of it with "Hey Cortana, take a picture" so that I could show you what I'm talking about, but the picture does not capture the hologram produced by the ThingMark.

Thoughts?

-Brent

Tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Moel and tracker not lining up with ThingMark

You must have the printed ThingMark be exactly the same size as the size specified in the Experience. You have made it 1 meter in the Experience, and 5 cm in reality, so what you are seeing is exactly what I would expect.

4 REPLIES 4

Re: Moel and tracker not lining up with ThingMark

You must have the printed ThingMark be exactly the same size as the size specified in the Experience. You have made it 1 meter in the Experience, and 5 cm in reality, so what you are seeing is exactly what I would expect.

Re: Moel and tracker not lining up with ThingMark

That is exactly what was wrong.  My assumption was that the scale of 1 was equivalent to the default printer Ted size.  You should make a note somewhere about the difference.  It's not obvious that that is happening.

Re: Moel and tracker not lining up with ThingMark

There is a line about this in the ThingMark section of the Getting Started document, but we will be sure to highlight this in the documentation before we ship with MVP. 

Re: Moel and tracker not lining up with ThingMark

I did see that when I was reading through, but I did not pick up on the fact that it uses meters for units.  I designed my model in mm so you can imagine what it looked like the first time I did it!

I would suggest making the units more obvious in Thingworx studio.  I don't think many people design in meters.  How hard is it to change the units in Thingworx Studio?  Many of the models I use are in inches, and I'd prefer to not have to scale them manually after importing them.