cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Multiple Issues with Thingworx Studio

SOLVED
Highlighted
Level 1

Multiple Issues with Thingworx Studio

Hi,

I am facing few problems with Thingworx Studio

When I lauch the Thingworx Studio the welcome screen shows error as "Error occurred, check logs". I am not sure why this is happening.

When I open Thingworx Studio. I can still see my earlier created projects, but I can't load them and when I try to create new one, even that is not working. I can see window as shown bleow:

Please find the logs below:

[16:00:34] Studio Version 1.8 (0.1.12.1082)

[16:00:34] Status Message: Version 1.8 (0.1.12.1082)

[16:00:34] Checking for updates from https://studio-download.vuforia.io/downloads/ThingworxMobileBuilderApp.application

[16:00:43] Starting node.exe

[16:00:43] debug: [twx-studio:logging] Debug logging enabled. DEBUG=twx-studio*,ar-extension*

[16:00:43] Mon, 16 Jan 2017 10:30:43 GMT twx-studio:logging DEBUG_FD=1 so the "debug" module will log to stdout instead of stderr

[16:00:43] info: [twx-studio:initializer] Node version: 6.9.1

[16:00:43] debug: [twx-studio:initializer] ThingWorxStudio dir:  C:\Users\sameergr\Documents\ThingWorxStudio

[16:00:43] debug: [twx-studio:initializer] Projects dir:  C:\Users\sameergr\Documents\ThingWorxStudio\Projects

[16:00:43] debug: [twx-studio:initializer] Extensions dir:  C:\Users\sameergr\Documents\ThingWorxStudio\Extensions

[16:00:43] debug: [twx-studio:initializer] ThingMarks dir:  C:\Users\sameergr\Documents\ThingWorxStudio\ThingMarks

[16:00:43] debug: [twx-studio:initializer] Move /VuforiaStudioEnterpriseExtensions

[16:00:43] (node:3212) DeprecationWarning: `DEBUG_FD` is deprecated. Override `debug.log` if you want to use a different log function (https://git.io/vMUyr)

[16:00:43] debug: [twx-studio:fileUtils] C:\Users\sameergr\Documents\VuforiaStudioEnterpriseExtensions does not need to be moved, it does not exist

[16:00:43] debug: [twx-studio:initializer] Move the projects dir

[16:00:43] debug: [twx-studio:fileUtils] C:\Users\sameergr\Documents\VuforiaStudioEnterpriseProjects does not need to be moved, it does not exist

[16:00:43] debug: [twx-studio:initializer] Initialize builderSettings

[16:00:43] debug: [twx-studio:index] Done with initialization

[16:00:44] debug: [twx-studio:index] Startup process.argv is ["C:\\Users\\sameergr\\AppData\\Local\\Apps\\2.0\\AGQK50HY.2AK\\ZWH4JWZ8.0LW\\thin..udio_cd45769e4d993f77_0000.0001_b83b4d91f9311a36\\node.exe","C:\\Users\\sameergr\\AppData\\Roaming\\ThingworxStudio\\studio-download.vuforia.io\\dist\\server\\index.js","C:\\Users\\sameergr\\Documents"]

[16:00:44] debug: [twx-studio:extension-manager] extensionName to require ves-ar-extension

[16:00:44] ar-extension version 1.8.290

[16:00:44] debug: [twx-studio:extension-manager] extensionName to require ves-basic-web-widgets-extension

[16:00:44] debug: [twx-studio:extension-manager] extensionName to require ves-sample-projects

[16:00:44] debug: [twx-studio:extension-manager] extensionName to require twx-data-provider

[16:00:44] debug: [twx-studioSmiley TonguerojectHelper] ["C:\\Users\\sameergr\\AppData\\Roaming\\ThingworxStudio\\studio-download.vuforia.io\\node_modules\\ves-ar-extension\\node_modules\\lodash\\index.js"]

[16:00:44] info: [twx-studio:index] *********** Preview listening on 127.0.0.1:4001

[16:00:44] info: [twx-studio:index] listening on 127.0.0.1:3000

[16:00:46] Proxying: http://localhost:3000

[16:00:46] Access URLs:

[16:00:46]  ----------------------------

[16:00:46]  Local: http://localhost:3001

[16:00:46]  ----------------------------

[16:00:46] Watching files...

[16:00:46] Proxying: http://localhost:4001

[16:00:46] Access URLs:

[16:00:46]  ----------------------------

[16:00:46]  Local: http://localhost:4000

[16:00:46]  ----------------------------

[16:00:47] debug: [twx-studio:sockets] a user connected

[16:01:10] debug: [twx-studio:sockets] a user connected

[16:01:10]  [0mGET /%7B%7BprojectType.imgPath%7D%7D  [32m200  [0m5.223 ms - 2122 [0m

[16:01:10]  [0mGET /%7B%7Bview.imgPath%7D%7D  [32m200  [0m4.737 ms - 2122 [0m

[16:01:10]  [0mGET /%7B%7BviewType.imgPath%7D%7D  [32m200  [0m4.254 ms - 2122 [0m

[16:01:10]  [0mGET /images/%7B%7Bw.name%7D%7D.png  [32m200  [0m4.192 ms - 2122 [0m

[16:01:10] debug: [twx-studio:sockets] EMIT builderSettings

[16:01:10] debug: [twx-studio:sockets] EMIT updateProjects

[16:01:10] debug: [twx-studio:sockets] EMIT updateProjects

[16:01:12] debug: [twx-studio:sockets] EMIT getProjectTypes

[16:01:16] debug: [twx-studioSmiley TonguerojectHelper] Copying /src/**/* to project, overwrite=false

[16:01:16] debug: [twx-studioSmiley TonguerojectHelper] Copying /**/* to project, skip /src/**/*,  overwrite=true

[16:01:16] debug: [twx-studioSmiley TonguerojectHelper] Symlink node_modules

[16:01:16] debug: [twx-studioSmiley TonguerojectHelper] Copy of project files complete

[16:01:16] debug: [twx-studioSmiley TonguerojectSettings] write project settings FacilityPlantNew

[16:01:16] debug: [twx-studio:utility:runProjectGulpTask] C:\Users\sameergr\AppData\Local\Apps\2.0\AGQK50HY.2AK\ZWH4JWZ8.0LW\thin..udio_cd45769e4d993f77_0000.0001_b83b4d91f9311a36\node.exe C:\Users\sameergr\AppData\Roaming\ThingworxStudio\studio-download.vuforia.io\node_modules\gulp\bin\gulp.js init cwd=C:\Users\sameergr\Documents\ThingWorxStudio\Projects\FacilityPlantNew

[16:01:17] info: [twx-studio:utility:runProjectGulpTask] [16:01:17] Using gulpfile ~\Documents\ThingWorxStudio\Projects\FacilityPlantNew\gulpfile.js

[16:01:17] Starting 'init-src'...

[16:01:17] Finished 'init-src' after 1.47 ms

[16:01:17] Starting 'init'...

[16:01:17] Finished 'init' after 8.96 μs

[16:01:17]

[16:01:17] error: [twx-studio:utility:runProjectGulpTask] (node:7124) DeprecationWarning: `DEBUG_FD` is deprecated. Override `debug.log` if you want to use a different log function (https://git.io/vMUyr)

[16:01:17]

[16:01:17] debug: [twx-studioSmiley TonguerojectHelper] buildApp FacilityPlantNew

[16:01:17] debug: [twx-studioSmiley TonguerojectHelper] write settings

[16:01:17] debug: [twx-studioSmiley TonguerojectSettings] write project settings FacilityPlantNew

[16:01:17] debug: [twx-studioSmiley TonguerojectHelper] copy runtime extensions

[16:01:17] debug: [twx-studioSmiley TonguerojectHelper] packageThemeSet

[16:01:17] debug: [twx-studio:themeManager] generating studio-designtime-vars.scss

[16:01:17] debug: [twx-studio:themeManager] generating studio-runtime-vars.scss

[16:01:17] debug: [twx-studio:themeManager] processThemes

[16:01:17] debug: [twx-studio:themeManager] Making theme:  twx-light , includePaths:  C:\Users\sameergr\AppData\Roaming\ThingworxStudio\studio-download.vuforia.io\node_modules\ves-ar-extension\src\ar\src-scaffold\ionic\scss

[16:01:17] debug: [twx-studio:themeManager] Building twx-light-theme-designtime.css

[16:01:17] debug: [twx-studio:themeManager] Making theme:  twx-dark , includePaths:  C:\Users\sameergr\AppData\Roaming\ThingworxStudio\studio-download.vuforia.io\node_modules\ves-ar-extension\src\ar\src-scaffold\ionic\scss

[16:01:17] debug: [twx-studio:themeManager] Building twx-dark-theme-designtime.css

[16:01:17] debug: [twx-studio:themeManager] Building twx-dark-theme.css

[16:01:17] debug: [twx-studio:themeManager] Building twx-light-theme.css

[16:01:18] debug: [twx-studio:themeManager] building system-widget-extensions-designtime.css

[16:01:18] debug: [twx-studio:themeManager] building app-designtime.css

[16:01:18] debug: [twx-studio:themeManager] building app.css

[16:01:18] debug: [twx-studio:themeManager] building system-widget-extensions.css

[16:01:18] debug: [twx-studio:themeManager] copying css files for selected theme twx-light

[16:01:18] debug: [twx-studioSmiley TonguerojectHelper] onBuild

[16:01:18] info: [twx-studioSmiley TonguerojectHelper] Building ves-ar-extension app: FacilityPlantNew

[16:01:18] Mon, 16 Jan 2017 10:31:18 GMT ar-extension:gulp-shared clean

[16:01:18] debug: [twx-studioSmiley TonguerojectHelper] pathDir C:\Users\sameergr\Documents\ThingWorxStudio\Projects\FacilityPlantNew

[16:01:18] debug: [twx-studioSmiley TonguerojectHelper] scaffoldDir C:\Users\sameergr\Documents\ThingWorxStudio\Projects\FacilityPlantNew\src-scaffold

[16:01:18] debug: [twx-studioSmiley TonguerojectHelper] copySrc

[16:01:18] Mon, 16 Jan 2017 10:31:18 GMT ar-extension:gulp-shared copySrc

[16:01:18] debug: [twx-studioSmiley TonguerojectHelper] buildApp

[16:01:18] Mon, 16 Jan 2017 10:31:18 GMT ar-extension:gulp-shared build

[16:01:18] Reloading Browsers...

[16:01:18] debug: [twx-studio:sockets] EMIT addProjectComplete

[16:01:18] debug: [twx-studio:sockets] EMIT updateProjects

[16:01:18] Mon, 16 Jan 2017 10:31:18 GMT ar-extension:gulp-shared compile view contents

[16:01:18] no script for Home

[16:01:18] debug: [twx-studio:sockets] EMIT updateProjects

[16:01:18] debug: [twx-studio:sockets] user disconnected

[16:02:23]  [0mGET /design/FacilityPlantNew  [32m200  [0m0.977 ms - 2122 [0m

[16:02:23] debug: [twx-studio:sockets] user disconnected

[16:02:24] debug: [twx-studio:sockets] a user connected

[16:02:24]  [0mGET /%7B%7BviewType.imgPath%7D%7D  [36m304  [0m0.450 ms - - [0m

[16:02:24]  [0mGET /images/%7B%7Bw.name%7D%7D.png  [36m304  [0m1.257 ms - - [0m

[16:02:24] debug: [twx-studio:sockets] EMIT builderSettings

[16:02:24] debug: [twx-studio:sockets] EMIT updateProjects

[16:02:24] debug: [twx-studio:upgradeProject] upgradeIfNeeded FacilityPlantNew

[16:02:24] Mon, 16 Jan 2017 10:32:24 GMT ar-extension:upgrade No upgrade needed:  1.8.290 1.8.290

[16:02:24] debug: [twx-studio:upgradeProject] Project does not need an upgrade.

[16:02:24] debug: [twx-studioSmiley TonguerojectSettings] write project settings FacilityPlantNew

Please help me with the same.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Multiple Issues with Thingworx Studio

Now I see from where it is coming, looks like there is some issue with your 'Node js' application that runs behind your local Studio. Did you modify/uninstall the application? The transition error (in your logs) deals with Node js. Also, Did you try accessing studio in a different browser?

Can you please make sure the node.js application is installed? Or I would suggest to try repair or re-install the node.js application. If you are using older version of Chrome, then try in the latest version.

Let me know,

Giri

14 REPLIES 14

Re: Multiple Issues with Thingworx Studio

Hello guys,

Please help me with this issue. I really got stuck up.

Regards,

Sameer Singh Rathoud

Re: Multiple Issues with Thingworx Studio

Sameer,

did you follow the instructions in the email that announced the new version? It says: please uninstall ThingWorx Studio and install it from scratch (more or less). I had issues with auto-upgrades with an earlier version and when I followed the instructions it worked fine.

Cheers, moritz

Re: Multiple Issues with Thingworx Studio

Hi Mortiz,

Thanks a lot for your reply.

I have removed everything from my earlier installation and did the fresh installation, Thingworx studio got opened once, but I was not able to drag anything in the 3D canvas section (model, thingmark etc), so I have reloaded the page and now everythng gone again.

When I click on my created experiences, it show as:

Please help.

Regards,

Sameer Singh Rathoud

Re: Multiple Issues with Thingworx Studio

By saying Fresh Install, do you also mean creating a Fresh project??

If you are using project from previous version, I would suggest - Exit the Studio application, Navigate to the ThingWorxStudio project directory -> Projects -> <project name>, Delete all the files EXCEPT "SRC, CSS, EXTENSIONS and appConfig". Restart the studio application, which will recreate all the directories and files. Now Open the Project, let me know if you still see the problem.

NOTE: Before deleting project directories and files, take a backup of the files (to be on safe-side).

Giri

Re: Multiple Issues with Thingworx Studio

Hi Giri,

Thanks for your response.

From fresh install I meant I have removed all the projects and Thingworx installation from my machine and ran the fresh setup.

I am really not very much concerned about my earlier projects. I just wanted Thingworx Studio should get opened on my machine. But only thing I see is:

Please help. I am really blocked.

Thanks in advance.

Regards,

Sameer Singh Rathoud

Re: Multiple Issues with Thingworx Studio

Sameer,

Looks fuzzy and puzzling!! If it is a fresh install, it shouldn't show this problem, especially the Debug_FD one. Make sure you have HOME or USERPROFILE env variables are inplace. you tried Exit application, is it correct?

-Giri

Re: Multiple Issues with Thingworx Studio

Hi Giri,

Thanks for your response.

I have USERPROFILE in place, but dont have HOME env variable.

what HOME should point to?

Apart from this I have tried to run the ThingWorx Studio on IE as well, and tried on crome after reseting all the setting and removed all the extensions from the browser, but still no success.

Please help.

Thanks and Regards,

Sameer Singh Rathoud

Re: Multiple Issues with Thingworx Studio

Configuring USERPROFILE variable should suffice. Studio looks for either of them.

Looks very strange!! Can you please try 'Inspect element' (Chrome dev tools) to debug/inspect on that page? Do let me know if you see any errors/warnings in Console | network | security logs.

Re: Multiple Issues with Thingworx Studio

Hi Giri,

Thanks a lot again.

I think you pointed at right place. I have few errors in the consol.

They are as follow:

Uncaught ReferenceError: module is not defined

Error: transition superseded

    at $StateProvider.$get (http://localhost:3000/js/main-production.js:16146:42)

    at Object.invoke (http://localhost:3000/js/main-production.js:22625:19)

    at http://localhost:3000/js/main-production.js:22419:37

    at getService (http://localhost:3000/js/main-production.js:22566:32)

    at injectionArgs (http://localhost:3000/js/main-production.js:22591:58)

    at Object.invoke (http://localhost:3000/js/main-production.js:22617:18)

    at http://localhost:3000/js/main-production.js:25726:43

    at forEach (http://localhost:3000/js/main-production.js:18140:20)

    at Object.<anonymous> (http://localhost:3000/js/main-production.js:25724:13)

    at Object.invoke (http://localhost:3000/js/main-production.js:22625:19) Possibly unhandled rejection: {}

Error: transition prevented

    at $StateProvider.$get (http://localhost:3000/js/main-production.js:16147:41)

    at Object.invoke (http://localhost:3000/js/main-production.js:22625:19)

    at http://localhost:3000/js/main-production.js:22419:37

    at getService (http://localhost:3000/js/main-production.js:22566:32)

    at injectionArgs (http://localhost:3000/js/main-production.js:22591:58)

    at Object.invoke (http://localhost:3000/js/main-production.js:22617:18)

    at http://localhost:3000/js/main-production.js:25726:43

    at forEach (http://localhost:3000/js/main-production.js:18140:20)

    at Object.<anonymous> (http://localhost:3000/js/main-production.js:25724:13)

    at Object.invoke (http://localhost:3000/js/main-production.js:22625:19) Possibly unhandled rejection: {}

Error: transition aborted

    at $StateProvider.$get (http://localhost:3000/js/main-production.js:16148:39)

    at Object.invoke (http://localhost:3000/js/main-production.js:22625:19)

    at http://localhost:3000/js/main-production.js:22419:37

    at getService (http://localhost:3000/js/main-production.js:22566:32)

    at injectionArgs (http://localhost:3000/js/main-production.js:22591:58)

    at Object.invoke (http://localhost:3000/js/main-production.js:22617:18)

    at http://localhost:3000/js/main-production.js:25726:43

    at forEach (http://localhost:3000/js/main-production.js:18140:20)

    at Object.<anonymous> (http://localhost:3000/js/main-production.js:25724:13)

    at Object.invoke (http://localhost:3000/js/main-production.js:22625:19) Possibly unhandled rejection: {}

Error: transition failed

    at $StateProvider.$get (http://localhost:3000/js/main-production.js:16149:38)

    at Object.invoke (http://localhost:3000/js/main-production.js:22625:19)

    at http://localhost:3000/js/main-production.js:22419:37

    at getService (http://localhost:3000/js/main-production.js:22566:32)

    at injectionArgs (http://localhost:3000/js/main-production.js:22591:58)

    at Object.invoke (http://localhost:3000/js/main-production.js:22617:18)

    at http://localhost:3000/js/main-production.js:25726:43

    at forEach (http://localhost:3000/js/main-production.js:18140:20)

    at Object.<anonymous> (http://localhost:3000/js/main-production.js:25724:13)

    at Object.invoke (http://localhost:3000/js/main-production.js:22625:19) Possibly unhandled rejection: {}

TypeError: Illegal invocation

    at Object.info (main-production.js:10310)

    at resetDebug (main-production.js:10367)

    at Scope.$digest (main-production.js:35597)

    at Scope.$apply (main-production.js:35863)

    at bootstrapApply (main-production.js:19624)

    at Object.invoke (main-production.js:22625)

    at doBootstrap (main-production.js:19622)

    at Object.bootstrap (main-production.js:19642)

    at HTMLDocument.<anonymous> (main-production.js:9936)

    at fire (third-party.js:3182)

TypeError: Illegal invocation

    at Object.info (main-production.js:10310)

    at resetDebug (main-production.js:10367)

    at Scope.$digest (main-production.js:35597)

    at Scope.$apply (main-production.js:35863)

    at n.wrapper (main-production.js:12203)

    at n.emit (socket.io.js:2)

    at n.onevent (socket.io.js:3)

    at n.onpacket (socket.io.js:3)

    at n.<anonymous> (socket.io.js:3)

    at n.emit (socket.io.js:2)

TypeError: Illegal invocation

    at Object.debug (http://localhost:3000/js/main-production.js:10317:35)

    at http://localhost:3000/js/main-production.js:1956:13

    at processQueue (http://localhost:3000/js/main-production.js:34431:37)

    at http://localhost:3000/js/main-production.js:34475:27

    at Scope.$eval (http://localhost:3000/js/main-production.js:35755:28)

    at Scope.$digest (http://localhost:3000/js/main-production.js:35569:31)

    at Scope.$apply (http://localhost:3000/js/main-production.js:35863:24)

    at n.<anonymous> (http://localhost:3000/js/main-production.js:12218:22)

    at n.onack (http://localhost:3000/socket.io/socket.io.js:3:6057)

    at n.onpacket (http://localhost:3000/socket.io/socket.io.js:3:5417) Possibly unhandled rejection: {}

WARNING: Tried to load angular more than once.

Uncaught ReferenceError: module is not defined

TypeError: Illegal invocation

    at Object.info (canvas-main-production.js:10318)

    at resetDebug (canvas-main-production.js:10375)

    at m.$digest (angular.min.js:145)

    at m.$apply (angular.min.js:148)

    at angular.min.js:21

    at Object.invoke (angular.min.js:43)

    at c (angular.min.js:21)

    at Object.Mc [as bootstrap] (angular.min.js:21)

    at HTMLDocument.<anonymous> (canvas-main-production.js:1648)

    at fire (third-party.js:3182)

Failed to parse SourceMap: http://localhost:3000/sass

Please help.

Thanks and Regards,

Sameer Singh Rathoud