cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to retrieve thingmarks

Level 1

Unable to retrieve thingmarks

in my project , I navigate to MyThingmark , it says retrieve the thingmarks from developer portal,i click on the link and fill my credential, but there comes error.All proxy is disabled, still it is not retrieving the thingmarks.

6 REPLIES 6

Re: Unable to retrieve thingmarks

Hi Qadir umar​,

Could you please try following:

Open ThingWorx Studio Home page and on Top Right; you will see three Dots (...).

Click on ... -> Portal login.

Enter your Studio Credentials and click on Configure.

It will configure your Experience Service URL and will also download the ThingMarks which you can use in your Project.

To confirm; go to ... -> Settings. Default ThingWorx Experience Service URL should show the Experience Server URL.

Please share ThingWorx Studio logs if it doesn't work.

Re: Unable to retrieve thingmarks

Hi Ankit,

     i go to Portal login and enter credential and click on configure.it gives me error auto configured failed.No thingmarks is downloaded.

Re: Unable to retrieve thingmarks

HI Qadir umar​,

Did you receive the welcome email for ThingWorx Studio containing the Experience Service url?

Are you able to access that url from your browser?

Thanks,

Ankit Gupta

Re: Unable to retrieve thingmarks

yes , i got all the thing.

Re: Unable to retrieve thingmarks

Hi Qadir umar​,

This seems some proxy error. Is your machine network inside some VPN?

If yes, could you please try it outside VPN.

Also, try doing nslookup <Experience Service Domain> from your machine and outside VPN if it can find the server's IP address?

If it shows different result; please check following Document for Proxy Setting: How to solve Proxy Script based configuration issues for Thingworx Studio.docx

Re: Unable to retrieve thingmarks

Thanks Ankit, let me try. What could be root cause of it because earlier i was not able to validate Experience service Url , then i disabled the proxy then it started working.