cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

4.0 Issue with Creo Agent and Windchill

Level 6

4.0 Issue with Creo Agent and Windchill

Hi, I am a student using an academic license of Creo 4.0 M030 with Windows 10. When ever I open Creo, I get error message about Creo Agent not initializing correctly. Offline actions work fine, but I can't use Windchill. Windchill is critical to my work and I need it back as soon as possible. This problem began when I upgraded from creo 3.0 to 4.0. Important things to note are: I confirmed that "creoagent.exe" is running when ever Creo is open; manually restarting this program, found in the PTC folder of my Program Files, doesn't help. Reinstalling all of Creo including the Agent doesn't help. Interestingly, in programs and features, Creo Agent does not show up as an installed program as it did in Creo 3.0. Editing enviroment variables, as suggested by this thread doesn't help. The steps in this obscure pdf didn't help either.

 

6 REPLIES 6

Re: 4.0 Issue with Creo Agent and Windchill

4.0 installs a new version of Creo Agent versus 3.0. You'll notice in Program and Features that there should be PTC Creo Platform Agent 3.133, which is used in 3.0, and PTC Creo 4 Platform Services, which is used in 4.0.

 

If creoagent.exe is in fact running with 4.0, I'd check whether it's actually the correct one. I use Process Explorer from Sysinternals, check the properties of the executable, and make sure that it's pointing to the correct one.

 

If it's not, try creating a batch file to startup Creo. In this batch file, define CREO_AGENT_EXE_PATH to the full path of creoagent (normally C:\Program Files\PTC\Creo\Platform\3.133\creoagent.exe or something like that). Preferably, use a DOS short path; sometimes it doesn't like spaces and DOS short paths have better security in ensuring that the path will resolve. Usually you don't need to set this variable, but occasionally (especially with multiple or network installs) the installer gets confused and mixes up where the creo agent executable actually is.

 

If you need help obtaining a DOS short path...copy the following into a batch file in the directory you want the shortpath of

 

@echo OFF
if '%1'=='' (%0 .) else echo %~s1

 

then cmd, cd into the directory that you want the shortpath of, and call that batch file.

Re: 4.0 Issue with Creo Agent and Windchill

The Agent seems correct and seems to be running fine. but I still get the error.e06b18b50e69ed485df349bfa0ae7cfe

Re: 4.0 Issue with Creo Agent and Windchill

Hi,

 

silly tip ... login as different user -OR- Administrator and launch Creo 4.0.


Martin Hanák

Re: 4.0 Issue with Creo Agent and Windchill

What was the resolution to this problem?

I have similar symptoms with a network install of Creo 4.

Re: 4.0 Issue with Creo Agent and Windchill

Put these lines at the start of your parametric.bat file or in a separate file that is called from parametric.bat.

 

@rem ***** Set Creo Agent *****
set CREO_AGENT_EXE_PATH=<Network_drive>:\PTC\CreoAgent\Agent\creoagent.exe
set CREO_AGENT_LDP_LIST=<Network_drive>:\PTC\CreoAgent\Platform\4\manifests

 

Replace the <Network_drive> with your network drive letter.

Re: 4.0 Issue with Creo Agent and Windchill

Thanks @BenLoosli for confirming what works for you.  I have those set using the PSF file.

 

Until I recently was granted temporary admin rights, I thought the problem was the creoagent.exe process (CREO_AGENT_EXE_PATH), but it turns out that is loading into memory from the network location fine IF I set my CREO_AGENT_LDP_LIST to a local installation folder. Now, it seems genlwsc.exe is the process that is getting blocked or somehow failing to start.

 

Is it possible that the Creo 4 requirement for Windows Update for Universal C Runtime (page 2 of Read This First document) applies to the server from which Creo is launched and NOT the workstation that is running it?