cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Visit the PTCooler (the community lounge) to get to know your fellow community members and check out some of Dale's Friday Humor posts! X

CREO Parametric 7 multiple graphics cards

EG_9176578
2-Guest

CREO Parametric 7 multiple graphics cards

We have a user that runs Parametric and Keyshot on an officially supported machine:
Dell Precision 3630 with Quadro P2200.

They have been getting crashes recently and I am struggling to locate the exact cause. I have noticed that Keyshot uses all available CPU resources as by design, but that does mean his other applications are fighting for resources.
My question: If I were to buy an Nvidia RTX 3000 series card (not Quadro) for Keyshot and run both cards in the system, can I force Creo to use the Quadro which is still supported? Or will Creo potentially use the unspported RTX?

1 ACCEPTED SOLUTION

Accepted Solutions
dnordin
15-Moonstone
(To:EG_9176578)

For the CPU issue with Keyshot, you can set the affinity (which CPU's are used) for the process so that it doesn't use all the CPU's available. 

  1. Run Keyshot
  2. Open the Windows task manager.
  3. Go to the Details tab.
  4. Find the Keyshot process
  5. Right - Click > Set Affinity
  6. Uncheck <All Processors>
  7. Check only 1/2 the processors (the second half).
  8. OK
  9. Do the same for the xtop.exe process and select the other half of the processors.  [not all Creo Parametric processes are threaded, but some are threaded]

As for the graphics question, you can use the NVIDIA control panel to define specific program settings.  You can select which graphics card to use for the program.  For Keyshot, select the RTX card and the P2200 for Creo Parametric.

 

Regards,

 

Dan N.

 

 

View solution in original post

4 REPLIES 4
dnordin
15-Moonstone
(To:EG_9176578)

For the CPU issue with Keyshot, you can set the affinity (which CPU's are used) for the process so that it doesn't use all the CPU's available. 

  1. Run Keyshot
  2. Open the Windows task manager.
  3. Go to the Details tab.
  4. Find the Keyshot process
  5. Right - Click > Set Affinity
  6. Uncheck <All Processors>
  7. Check only 1/2 the processors (the second half).
  8. OK
  9. Do the same for the xtop.exe process and select the other half of the processors.  [not all Creo Parametric processes are threaded, but some are threaded]

As for the graphics question, you can use the NVIDIA control panel to define specific program settings.  You can select which graphics card to use for the program.  For Keyshot, select the RTX card and the P2200 for Creo Parametric.

 

Regards,

 

Dan N.

 

 

Thats great thank you! I will try setting the CPU affinity and get an RTX card.

Hi,

if your user runs Keyshot frequently and for demanding tasks then I suggest to buy separate PC for Keyshot.

Note: I guess that Keyshot produces slightly different results when using GPU instead of CPU.


Martin Hanák

Thanks for your help, we ended up buying a Quadro RTX 5000 as the machine only has one PCIE x16 slot. The performance has dramatically improved and no more crashes running Keyshot in GPU mode. 

Top Tags