cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Collision between Windows 10 version 1803 (April 2018 Update) and FLEXnet 11.14

MartinHanak
23-Emerald V

Collision between Windows 10 version 1803 (April 2018 Update) and FLEXnet 11.14

Hello,

 

today one of our computers updated to Windows 10 version 1803 (April 2018 Update). The update killed lmadmin_ptc service (i.e. license manager). I was able to uninstall FLEXnet 11.14, but I am not able to install FLEXnet 11.14 ... installer cannot create lmadmin_ptc service.

 

If you have any tip how to solve the problem without uninstalling version 1803, please let me know.


Martin Hanák
16 REPLIES 16

We recently had our IT guys rename our server without telling anyone and somehow kill our license server. I had a lot of trouble uninstalling then re-installing the server (11.14, also for Creo 4.0 usage). It would say it was starting, but wouldn't start the ptc_d daemon and after a minute or two it was not running.

The eventual solution, done by a PTC license guy, was to remove the 64-bit version of the FlexNet stuff, and instead use the 32 -bit version. It's been okay since. I wish I'd done it myself, so I'd have all the intricate details, but hopefully this might be a start for you.

Just information...

 

I tested the problem "FLEXnet 11.14 cannot be installed on Windows 10 Pro (Czech) version 1803" in my environment.

 

I did a clean installation of Windows 10 Pro (English) version 1803 and Windows 10 Pro (Czech) version 1803, too. In both Cases I was able to put FLEXnet 11.14 into operation using known trick ... uninstall/install.

 

Unfortunately I still do not know how I will solve the problem on customer's PC. Is there any log file written during FLEXnet 11.14 installation and providing useful information about installation problem ?


Martin Hanák

Me too have this problem! Smiley Frustrated

I had search and try below link from Japan but can't solve until now...

http://3d.rikei.co.jp/faq/20180509-ptc-creo-license-support-unable-launch-creo-after-windows10-updat...

 

 

 

Solution no.1:

  1. uninstall FLEXnet 11.14
  2. install FLEXnet 11.14

Does it work for you ?

 


Martin Hanák

Hello Martin Hanák,

FLEXnet 11.14 is come from which version disc?

I using the license from disc Wildfire 5.0, due to I major use Wildfire 5.0. Reinstall is not work (lmadmin_ptc still missing).

And I try  to install the license from disc Creo 3.0 instead the Flexlm, it can open Creo 3.0 but can't open Wildfire 5.0. 

Now I recover to the old Win 10 and stop the update service to using both Wildfire & Creo...


@ptc-4689762 wrote:

Hello Martin Hanák,

FLEXnet 11.14 is come from which version disc?

I using the license from disc Wildfire 5.0, due to I major use Wildfire 5.0. Reinstall is not work (lmadmin_ptc still missing).

And I try  to install the license from disc Creo 3.0 instead the Flexlm, it can open Creo 3.0 but can't open Wildfire 5.0. 

Now I recover to the old Win 10 and stop the update service to using both Wildfire & Creo...


1.] FLEXnet 11.14 is available on Creo 4.0 installation DVD (I prefer separate installation package ... see 2.])

 

2.] to download separate FLEXnet 11.14 installation package go to https://support.ptc.com/WCMS/files/121640/en/PTC_LMS_Download.pdf document

 

3.] to run Wildfire 5.0 and Creo 3.0 you do not have to install FLEXnet 11.14, you can install FLEXnet 10.8 from Wildfire 5.0 DVD ... Creo 3.0 works with FLEXnet 10.8

 

4.] NOTE: I do not know whether your Creo license is locked or floating. If it is locked then you do not need to install FLEXnet ... Creo installer needs to know path to license file, only.

 

 


Martin Hanák

Hello Martin Hanák,

Looks your link helpful, but which type ( Lmadmin / Lmgrd) should best for my case ( run Wildfire 5.0 and Creo 3.0)?

Already try reinstall FLEXnet 10.8 from Wildfire 5.0 DVD, not work since update to Win 10 (1803).

I using the floating license.

 


@ptc-4689762 wrote:

Hello Martin Hanák,

Looks your link helpful, but which type ( Lmadmin / Lmgrd) should best for my case ( run Wildfire 5.0 and Creo 3.0)?

Already try reinstall FLEXnet 10.8 from Wildfire 5.0 DVD, not work since update to Win 10 (1803).

I using the floating license.

 


Install Lmadmin firstly, if it does not work install Lmgrd.


Martin Hanák

Just finished dealing with this issue (for the second time in a year).  I did this:

  1. Downloaded Creo 4 M040 web installer
  2. Selected license setup
  3. Removed the old server which was showing "unavailable"
  4. Reinstalled a new license server by dragging in the license text file

Seems OK now.  I checked the service and it's set to "automatic start" so all should be good.  What a pain this is!

Invisigoth
14-Alexandrite
(To:MartinHanak)

Hello all,

 

I just ran into this today.  Windows 10 upgraded to 1803 overnight and sure enough lmadmin_ptc is gone from the services app.  Started lmadmin.exe from the command line so that the students can obtain licenses for now. What a pain in the ***.

 

Since they haven't fixed SPR 7094575 yet, clearly this is leftover pain from when this was first reported for Windows 10 1709.  I can't really fault PTC, as Windows 10 Updates wreak havoc on all sorts of installed software and hardware too.

 

The original PTC doc on this says "Workaround: Manually configure lmgrd service 11.14 ".  I take that to mean run the Windows sc.exe command and re-create the service.  Has anyone tried that?

 

 

 

 

 


@Invisigoth wrote:

Hello all,

 

I just ran into this today.  Windows 10 upgraded to 1803 overnight and sure enough lmadmin_ptc is gone from the services app.  Started lmadmin.exe from the command line so that the students can obtain licenses for now. What a pain in the ***.

 

Since they haven't fixed SPR 7094575 yet, clearly this is leftover pain from when this was first reported for Windows 10 1709.  I can't really fault PTC, as Windows 10 Updates wreak havoc on all sorts of installed software and hardware too.

 

The original PTC doc on this says "Workaround: Manually configure lmgrd service 11.14 ".  I take that to mean run the Windows sc.exe command and re-create the service.  Has anyone tried that?

 


Hi,

solution no.1:

  • uninstall FLEXnet 11.14
  • install FLEXnet 11.14

solution no.2

  • create new empty C:\flexnet directory
  • copy contents of C:\Program Files\PTC\FLEXnet Admin License Server directory into C:\flexnet directory
  • uninstall FLEXnet 11.14
  • launch C:\flexnet\x86e_win64\obj\lmtools.exe application and create lmgrd-based service to start FLEXnet 11.14 ... see page 69 in attached PDF file.

 


Martin Hanák
Invisigoth
14-Alexandrite
(To:MartinHanak)

Thanks Martin.  It was just easier to uninstall/reinstall.  At least it is good to know that tried and true method still works!

auijttewaal
5-Regular Member
(To:MartinHanak)

My colleague did NOT uninstall but just reconfige the license and it worked...

 

But on a different laptop I cannot get any version to work; 11.14.1.2, or 10.8 with the features of 11.14 or the manual installation of lmgrd.exe

Hi,

 

my notes ...

1.] You cannot use FLEXnet 10.8, if you need to work with Creo 4.0 or higher.

2.] FLEXnet 11.14.1.2 needs Visual Studio 2010 (VC++ 10.0) SP1 installed in Windows

3.] FLEXnet does not work if virtual network card is installed in Windows

 

I cannot give you an advice how to solve the problem on laptop ... I do not have access to this computer.


Martin Hanák
auijttewaal
5-Regular Member
(To:MartinHanak)

Hi Martin,

 

In this case after trying everything I just started again with

Disabling the firewall,  run the setup of 11.14.1.2 and enable firewall afterwards with exeption for port 7788 in inbound and outbound rules. It worked! (thought I tried it before, but apparently not)

 

You CAN install 10.8 for Creo 4 as long as you copy the ptc_d.exe and lmgrd.exe into it from a 14.11 version. We only use it when all other options have failed.

Hi,

 

just couple of notes.

 

1.] FLEXnet 10.8 installation with replaced ptc_d.exe and lmgrd.exe is not FLEXnet 10.8 installation [from my point of view :)]

 

2.] When PC has assigned its own Creo license, then it is not necessary to define Windows Firewall rule. Windows Firewall rule must be defined if license request is sent from different PC, only.

 

3.] When PC has assigned its own Creo license, then it is necessary to define firewall rule if non-Windows firewall software is installed (for example ESET Personal Firewall).

 

4.] I define Inbound Firewall rules for lmadmin.exe. lmgrd.exe, ptc_d.exe programs, only. I do not define Inbound Firewall rules for TCP ports.


Martin Hanák
Announcements