cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creo 4 Stop working after Windows 10 update 1903 with thunderbolt dock

Highlighted
Participant

Creo 4 Stop working after Windows 10 update 1903 with thunderbolt dock

With windows 10 update from 1809 to 1903, Creo 4 M40 doesn't start anymore (no error message), and Creo View 4.1 is unable to display 3Ds (Creo View starts and display the structure of the 3D models but doesn't display any 3D).

 

The computer used, a Laptop Dell Precision 3530 equipped with a Intel processor i5-8400H CPU at 2.5GH, Installed RAM 16.0GB & Integrated Intel UHD 630 Graphics processor, is connected to 2 Dell screens E2313H (1920x1080) through a Dell Universal Dock D6000 using a thunderbolt connection.

 

Creo 4 M40 and Creo View 4.1 with Windows 10 update 1903 can only start properly when disconnected from the dock station. Creo 4 M40 and Creo View 4.1 will continue to work properly when the computer is re-connected to the dock after being started undocked. Before the windows update 1903, Creo 4 M40 and Creo View 4.1 were starting and working properly with the Laptop and the 2 screens connected to the dock station.

 

Any idea of the source of the problem or clue for a solution without doing any regression in the drivers or windows update (IT security constrain - All drivers and Windows 10 shall be at the latest revision)?

14 REPLIES 14

Re: Creo 4 Stop working after Windows 10 update 1903 with thunderbolt dock

@themecat 

Did you get a chance try latest available datecode of Creo 4.0 ... M090? 

Re: Creo 4 Stop working after Windows 10 update 1903 with thunderbolt dock

No, per group IT policy I am locked up with M040...

Re: Creo 4 Stop working after Windows 10 update 1903 with thunderbolt dock

With several of the Windows updates we have seen computers need to have their graphics drivers updated. I usually try to stick with the latest one from the PC manufacturer (HP in our case, Dell in yours) but have had to to directly to Nvidia at times.

Re: Creo 4 Stop working after Windows 10 update 1903 with thunderbolt dock

Try reinstalling the application and if possible disable firewall or antivirus application. 

Re: Creo 4 Stop working after Windows 10 update 1903 with thunderbolt dock

When screen are connected through the thunderbolt dock the Nvidia drivers are not solicited (Nvidia Control Panel Error message: NVIDIA Display settings are not available. You are not currently attached to an NVIDIA GPU.). Dell manufacturer graphic drivers are all to the latest revision.

Re: Creo 4 Stop working after Windows 10 update 1903 with thunderbolt dock

Already done 2 times on 2 different laptops (one starting with a clean/new windows installation) with the exact same hardware configuration, same results the Windows 10 update problem can be duplicated.

Re: Creo 4 Stop working after Windows 10 update 1903 with thunderbolt dock

In my opinion, getting latest datecode on one of the machines to test the issue can help. It may help in planning for next action. 

 

Do you see xtop.exe in Task Manager > Details on starting Creo? 

Re: Creo 4 Stop working after Windows 10 update 1903 with thunderbolt dock

As previously answered we are locked-up with M040... And the issue is not only with Creo 4 M040 but also with Creo View 4.1.

When starting Parametric.exe can be seen, after selecting the configuration wanted, xstop.exe can be seen, then parametric.exe and xstop.exe are stopping.

For Creo view, productview.exe starts the Model Structure can be seen, but the 3D is not displayed and productview.exe increases the CPU usage up to 100% indefinitely...

Only way to have Creo 4.0 M040 and Creo View 4.1 working with the 2 screens connected to the dock is to disconnect the Laptop from the dock start Creo 4.0 or Creo view (for Creo View the model needs also to be loaded when disconnected from the dock) and re-connect the Laptop to the dock to use the 2 screens.

Re: Creo 4 Stop working after Windows 10 update 1903 with thunderbolt dock

Some computers have the ability to set what graphics card is used for which display. You might look into that in the windows settings. The other thing I have done at times is to go into the BIOS and force the use of the Nvidia card. I'm not sure what the setting would be called in a Dell but in HP it has to do with the Hybrid graphics.