cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Curve Display in Creo 2

Topaz II

Curve Display in Creo 2

Creo 2, M010

Windows7 64

Nvidia FX3800, driver 270.90



I keep finding new annoyances in Creo 2. The image below is a top view
of a simple skeleton model. A few planes and a couple of curves, no
surface or solid geometry. Notice the curves, in blue, appear straight.
They are not. The highlight, in green, shows the true arc of the blue
curve directly above it. It's a single, gentle arc, yet Creo displays
it as a straight line, actually the chord of the arc. This part is in
inches, and the R to L width of that image is about 3", so it's not a
tiny arc.



This happens in drawings and sections and is more than just annoying. I
sometimes can't tell why Creo won't let me select the sketch and it
turns out I'm clicking on the straight line display while the arc is
actually many pixels away so I'm nowhere near it.



I didn't have these issues in Wf5 & earlier. Is there a config option
or display setting I'm missing?



Thanks,





Doug Schaefer
--
Doug Schaefer | Engineering Manager
Crow Works
4 REPLIES 4

RE: Curve Display in Creo 2

Have you tried changing your edge quality?


Just wondering if this has anything to do with it.



"Too many people walk around like Clark Kent, because they don't realize they can Fly like Superman"

Curve Display in Creo 2

I had thought it was set to 'Very High', but it was at 'High'. However,
changing it made no difference.


This and suing anti-aliasing are the only suggestion I've gotten.
Anti-aliasing seemed to degrade performance, so I turned it back off but
when I get more time I plan to look into it further.



The only other reply was "please let me know if you find a fix!" It's
really ridiculous in a high CAD system (with 25 years and 30 versions
under its belt) to look at gentle arcs on screen and actually see
straight lines. This is like ACAD circa 1990.



Based on how buggy Creo 2.0 is, boy I hope we never have to work with
Creo 1.0.



Doug Schaefer
--
Doug Schaefer | Engineering Manager
Crow Works

RE: Curve Display in Creo 2

Hi all,


I was able to reproduce this issue on my own workstation. However, when I opened the same part that showed this issue on a Windows XP computer I did not have any trouble at all. Edit: a closer look learned this is not true. Repaint of the screen caused bad display of curve.


in Windows 7.



Anybody any clue on this?



Best regards,


Menso

RE: Curve Display in Creo 2

I noticed my edited post does not seem to get mailed, so see below.


Bottom line it seems to be an OpenGL thing.



Best regards,


Menso




In Reply to Menso Heij:



Hi all,


I was able to reproduce this issue on my own workstation. However, when I opened the same part that showed this issue on a Windows XP computer I did not have any trouble at all. Edit: a closer look learned this is not true. Repaint of the screen caused bad display of curve.


in Windows 7.



Anybody any clue on this?



Best regards,


Menso