cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

FlexLM Installation for Creo 7

SOLVED
Highlighted

FlexLM Installation for Creo 7

Hello,

So I went to install the license server for Creo 7 on my license server and it does not want to use the NIC mac address that the current license server is using on the same machine.  Has anyone else seen this and know why it is doing this or how to get around it?  When I do ipconfig /all, it shows 4 NICs and the one it is picking is the last one in the list.

**Update*** I have two NICs that are teamed.  The current license uses the teamed NIC MAC.  I have disabled the 4th NIC which is something Dell has for the SAN but we have found unnecessary.  But now the new license server wants one of the NICs and not the teamed NIC.  Any ideas?

Thank you,

Brian

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: FlexLM Installation for Creo 7


@BrianToussaint wrote:

Hello,

So I went to install the license server for Creo 7 on my license server and it does not want to use the NIC mac address that the current license server is using on the same machine.  Has anyone else seen this and know why it is doing this or how to get around it?  When I do ipconfig /all, it shows 4 NICs and the one it is picking is the last one in the list.

**Update*** I have two NICs that are teamed.  The current license uses the teamed NIC MAC.  I have disabled the 4th NIC which is something Dell has for the SAN but we have found unnecessary.  But now the new license server wants one of the NICs and not the teamed NIC.  Any ideas?

Thank you,

Brian


Hi,

1.]

Creo 4.0 installation package includes FLEXnet 11.14 -OR- FLEXnet 11.14.1.2

2.]

Creo 7.0 installation package includes FLEXnet 11.16.2.1

3.]

It is not mandatory to install FLEXnet 11.16.2.1 when you want use Creo 7.0. Just replace the contents of the license file.

4.]

Creo 7.0 will work with FLEXnet 11.14.1.2 (I hope that with FLEXnet 11.14, too).

 


Martin Hanák

View solution in original post

5 REPLIES 5
Highlighted

Re: FlexLM Installation for Creo 7

@BrianToussaint, Is there a Flexnet license server for PTC product available on the same server machine?  When you say current server NIC mac address - Which server is this? is it Flexnet server (for PTC product or other product)?

 

License server will look for NIC which is active and high on priority.

You can type netconfig rdr command in command prompt to know which mac address is active on the machine.

 

Also you can check under registry network cards which NIC (adapter ) is on priority. Its suggested to generate the license file on active and on high priority network card mac address.

 

If you still have issue create a case with PTC technical support for further assistance.

Highlighted

Re: FlexLM Installation for Creo 7

@Sanath - Yes the Creo Flexnet server is currently on this machine.  I am able to run Creo 4 and Creo 6 on this machine.  I am trying to update so that I can run Creo 7.  In the current configuration I have 2 NICs that are teamed.  The current Flexnet is pointing to the teamed MAC address.  I do have a call open and tech support is saying that it doesn't use the teamed MAC.  I don't know if this has changed in what I am trying to load since what I do have is pointing to the teamed address.  Thank you for the registry info.  I will have to go in and set one to be the primary so that I can get a license file for that MAC.  I hope that answers your questions.

Highlighted

Re: FlexLM Installation for Creo 7

@BrianToussaint, if the existing license file and the new license file for Creo Parametric 7.0 are on same host id/mac address, try to update the server as per the below article and see if that helps to start the server. If not then its better you have a WebEx session with Technical Support to figure out the problem.

 

https://www.ptc.com/en/support/article/CS177819

 

 

Highlighted

Re: FlexLM Installation for Creo 7


@BrianToussaint wrote:

Hello,

So I went to install the license server for Creo 7 on my license server and it does not want to use the NIC mac address that the current license server is using on the same machine.  Has anyone else seen this and know why it is doing this or how to get around it?  When I do ipconfig /all, it shows 4 NICs and the one it is picking is the last one in the list.

**Update*** I have two NICs that are teamed.  The current license uses the teamed NIC MAC.  I have disabled the 4th NIC which is something Dell has for the SAN but we have found unnecessary.  But now the new license server wants one of the NICs and not the teamed NIC.  Any ideas?

Thank you,

Brian


Hi,

1.]

Creo 4.0 installation package includes FLEXnet 11.14 -OR- FLEXnet 11.14.1.2

2.]

Creo 7.0 installation package includes FLEXnet 11.16.2.1

3.]

It is not mandatory to install FLEXnet 11.16.2.1 when you want use Creo 7.0. Just replace the contents of the license file.

4.]

Creo 7.0 will work with FLEXnet 11.14.1.2 (I hope that with FLEXnet 11.14, too).

 


Martin Hanák

View solution in original post

Highlighted

Re: FlexLM Installation for Creo 7

@MartinHanak 

Thank you for your response.  I had misread "recommends" for "required" when I downloaded Creo 7 and what the license server needed to be.  Back in December when I changed servers I installed Flex from Creo 4 and thought that the version I installed was 11.14.1.2 but it turns out I had the Creo 4 with 11.16.2.1.  It makes no sense on why Creo 4 was able to pick up the teamed NIC and Creo 7 cannot.  When talking this over with IT, they can't understand why companies still use the mac address for licensing.  Creo isn't the only things we have in house that use it.  If there isn't a enhancement request out there that I can vote on to change it, I will be creating one in the near future.

Announcements