cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - If community subscription notifications are filling up your inbox you can set up a daily digest and get all your notifications in a single email. X

Importing large .stp files takes longer when connected to windchill server?

Cygnus_A
4-Participant

Importing large .stp files takes longer when connected to windchill server?

I am using Creo Parametric 3 on a fairly powerful workstation:

CPU: i7 6700k

RAM: 64 GB

HD: 1TB .m2 SSD

GPU: Quadro P4000

 

We have struggled with opening large .pkg and .stp files from vendors. I have an example file that takes 3-4 hours to import. However, I discovered that if I select <NO SERVER> under Server Management, the file can be opened in 30 minutes. I didn't think anything was being written or uploaded to the Windchill server at this point, so why is there such a significant difference in open times? Are there settings or options in Creo or Windchill that would decrease this time impact? Any help would be appreciated. This is severely impacting our workflow.

3 REPLIES 3
BenLoosli
23-Emerald II
(To:Cygnus_A)

The reason for the time delay when connected to Windchill is that every file created on the fly from the imported file has to have its file name checked against the Windchill DB to see if that file already exists. And then Windchill has to check the indexes of all workspaces to see if someone else may have that file name checked out or downloaded. It doesn't matter to Windchill if it finds no existing files, the data checks must be performed.

 

Cygnus_A
4-Participant
(To:BenLoosli)

Interesting. Is there any way to delay these data checks until we are ready to upload the file to the server?

RandyJones
19-Tanzanite
(To:Cygnus_A)

Make sure the default templates that are being used to create your prt/asm/dwg's including any needed formats are added to your workspace before you start the import. Any time you import a step model Creo Parametric is using the default template you have defined to create the new model. If this is not in the workspace then Creo Parametric loads this template from Windchill, without saving it to the workspace, for every prt/asm/drw created.

Doing this will significantly decrease the time needed to import step files. Also make sure your config option show_geom_checks_on_creation is set to no otherwise the import will pause for user input if a geometry check is encountered during import.

Top Tags