cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need to share some code when posting a question or reply? Make sure to use the "Insert code sample" menu option. Learn more! X

Jlink STD.out message "REVISION 0.0"

amedina
1-Newbie

Jlink STD.out message "REVISION 0.0"

I get this in the STD.out file:

"For faster startup please add "REVISION 0.0" to
C:\apps\ptc\COOL_PROGRAM\protk.dat"

The program runs and there seems to be no issue. Is there something I'm
missing that is making it too slow or some such? My first guess is that this
is something to do with "java_path" or the Java 2 option that one sets in
the config.pro. I got no idea how to correct it or why its slow, it doesn't
feel/seem slow.

regards,

Alfonso

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
3 REPLIES 3
bfrandsen
6-Contributor
(To:amedina)

There is no explanation of this entry in the documentation.
My guess has always been, that it is used to mark the version of the CAD
tool. In my J-Link apps for WF4 I have inserted REVISION 29.0 and gets no
warning.
Some toolkit apps have set it to 28.0 for WF4.
If anybody knows what it is used for and how, please enlighten the
community.
/Bjarne



aome dina <->
12-10-2011 01:47
Please respond to
aome dina <->


To
<->
cc

Subject
[proecus] - Jlink STD.out message "REVISION 0.0"






I get this in the STD.out file:

"For faster startup please add "REVISION 0.0" to
C:\apps\ptc\COOL_PROGRAM\protk.dat"

The program runs and there seems to be no issue. Is there something I'm
missing that is making it too slow or some such? My first guess is that
this is something to do with "java_path" or the Java 2 option that one
sets in the config.pro. I got no idea how to correct it or why its slow,
it doesn't feel/seem slow.

regards,

Alfonso



Site Links: View post online View mailing list online Send new post
via email Unsubscribe from this mailing list Manage your subscription
Use of this email content is governed by the terms of service at:

TAN 144494says following:


Certain J-Link programs compiled well after Pro/ENGINEER release 18.0 cause the following message to be reported in the std.out when loaded automatically into Pro/ENGINEER Wildfire 4.0:

A pre 18.0 Pro/DEVELOP application "<program name=">" was found.
For faster startup please add "REVISION 0.0" to <protk.dat>"


The version check causing this message to be displayed currently has an error and has been addressed Pro/ENGINEER Wildfire 5.0. See Alternate Technique.


The error has no impact on performance and can be safely ignored. For users wishing to prevent the error message being reported to std.out add the line "REVISION 0.0" to each auxiliary application entry in the protk.dat.

To my knowledge, this option was used for several releases. It is not
currently used.

Bob

Bob Monat
Jerand Technical Services, Inc.
bob@jerand.com
www.jerand.com
1-317-875-6087


On Wed, Oct 12, 2011 at 1:59 AM, Bjarne Frandsen <->wrote:

>
> There is no explanation of this entry in the documentation.
> My guess has always been, that it is used to mark the version of the CAD
> tool. In my J-Link apps for WF4 I have inserted REVISION 29.0 and gets no
> warning.
> Some toolkit apps have set it to 28.0 for WF4.
> If anybody knows what it is used for and how, please enlighten the
> community.
> /Bjarne
>
>
> *aome dina <->*
>
> 12-10-2011 01:47
> Please respond to
> aome dina <->
>
> To
> <->
> cc
> Subject
> [proecus] - Jlink STD.out message "REVISION 0.0"
>
>
>
>
> I get this in the STD.out file:
>
> "For faster startup please add "REVISION 0.0" to
> C:\apps\ptc\COOL_PROGRAM\protk.dat"
>
> The program runs and there seems to be no issue. Is there something I'm
> missing that is making it too slow or some such? My first guess is that this
> is something to do with "java_path" or the Java 2 option that one sets in
> the *config.pro*
Top Tags