cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about PTC Community Badges. Engage with PTC and see how many you can earn! X

ModelCheck cannot start

TL_rookie
5-Regular Member

ModelCheck cannot start

Hello All!

I'm trying to use ModelCheck (with Creo 8.0.5.0), but all it does is just these messages:
ModelCHECK - Unable to determine loadpt directory
ModelCHECK is disabled.

 

What I've checked / set: 
- ModelCheck component is installed
- config.pro contains both "modelcheck_enabled (yes)" and "modelcheck_dir"

- "mcdir" env. variable added
- I use Creo in English, but I also tried the lang=c env. variable

- the custom ModelCheck directory contains the "config" folder

 

What (else) must be done to make the ModelCheck work?

Thank you in advance!

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,

try adding following line at the end of parametric.psf file located in Parametric\bin subdirectory

 

ENV=PRO_LANG=english

-OR-

ENV=PRO_LANG=usascii

 


Martin Hanák

View solution in original post

9 REPLIES 9

Take a look here:

TL_rookie
5-Regular Member
(To:VladimirN)

Have read both already, done everything from CS30748 - no use.

@Mahesh_Sharma Please take a look.

Hi @TL_rookie

 

Couple of questions which may help debugging this issue,

 

1. Is Creo installed locally? 

2. Are you using some script to start application?

3. Test the issue by simply removing the config file. 

4. If Creo is installed under Program files, try reinstalling application in some other location (e.g. C:\PTC), if possible. 

5. Is machine OS is English?

 

Thanks. 

Mahesh 

TL_rookie
5-Regular Member
(To:Mahesh_Sharma)

Hello Mahesh,

 

Thanks!

Here are the answers:

1. Is Creo installed locally? --- yes

2. Are you using some script to start application? --- no

3. Test the issue by simply removing the config file. --- you mean remove the config.pro what is used by default? Makes no difference.

4. If Creo is installed under Program files, try reinstalling application in some other location (e.g. C:\PTC), if possible. --- will try, but how can it effect anything?

5. Is machine OS is English? --- no

Hi @TL_rookie 

 

4. If Creo is installed under Program files, try reinstalling application in some other location (e.g. C:\PTC), if possible. --- will try, but how can it effect anything?

- This will confirm that it is not something related to permissions or something like that

5. Is machine OS is English? --- no

- Which language? 

 

Remove MC_DIR if it is already set and have only config option modelcheck_dir. Also, make sure that the value of config option is up to folder containing config directory (do not include config directory).

IN addition to this check license as well in session to confirm ModelCHECK license is in session (File > Help > System information)

 

Thanks. 

TL_rookie
5-Regular Member
(To:Mahesh_Sharma)

Hello Maesh!

 

4. If Creo is installed under Program files, try reinstalling application in some other location (e.g. C:\PTC), if possible. --- will try, but how can it effect anything?

- This will confirm that it is not something related to permissions or something like that

--- I will try, but leave it to be the last option

 

5. Is machine OS is English? --- no

- Which language? 

--- Hungarian (Win10 Enterprise 22H2), Creo is English

 

"Remove MC_DIR if it is already set and have only config option modelcheck_dir" --- this is how it was earlier. First we added the modelcheck_dir to the config.pro and as the modelcheck did not work, the MCDIR env. variable had been added too.  
Shall the "lang=C" must be removed too?


ModelCheck is installed (see pic.)

 

Hi,

try adding following line at the end of parametric.psf file located in Parametric\bin subdirectory

 

ENV=PRO_LANG=english

-OR-

ENV=PRO_LANG=usascii

 


Martin Hanák
TL_rookie
5-Regular Member
(To:MartinHanak)

Thank you, Martin! 
It works now! 🙂

Top Tags