cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Opening Drawings with Missing Models/Assemblies in Parametric 3.0

Newbie

Opening Drawings with Missing Models/Assemblies in Parametric 3.0

I run into a lot of drawings that have missing models and or assemblies.  They are not used in the drawing, but just in there for no apparent reason.  Someone just re-used the part for something else.  I normally just create an empty assembly with the same name as the missing one in the drawing in order for the drawing to open up.  I can then delete the unused assembly and fix the drawing.

 

Is there a config.pro setting or a better Pro/Workaround for allowing me to open these drawings without having to trick the software?  It's very annoying.  I can't figure out any reason why PTC would kill a drawing this way.

 

Thanks,

 

Matt

7 REPLIES 7

Re: Opening Drawings with Missing Models/Assemblies in Parametric 3.0

An easier method:  File>Open>[drawing>Open Rep, select No Views.  This retrieves the drawing without its models, and suppresses solid views and freezes repeat regions.  You may then (delete any views of the relevant models if there were some), Drawing Models > Del Models the undesired models.  Tools > Drawing Representation > Execute > All Views will then load up the remaining existing models, presuming you want to continue work on the drawing right away.  If you don't, you can just save it in the No Views state, it won't hurt it beyond lacking saved display.

Re: Opening Drawings with Missing Models/Assemblies in Parametric 3.0

Sometimes I've come across a drawing where none of the usual methods will remove the odd references.  Here's what (so far) has always worked for me:

 

  1. create a new drawing, e.g. new.drw - no models
  2. Insert > Import Drawing/Data – choose problem drawing (we’ll say it’s a.drw for this example) - now in new.drw, sheet 2 and beyond are from a.drw
  3. delete sheet 1; rename the other sheet(s) if desired
  4. save as a.drw (overwrite original a.drw)

Re: Opening Drawings with Missing Models/Assemblies in Parametric 3.0

Thanks for the advice Matthew, but it doesn't work for me (unless I'm not following your workflow correctly).  The only way I can get the drawings open is if I select "View Only".  After that, I only have the option to retrieve models, which also fails.  I'm thinking that the missing models are set to be the Master Rep.

Matt

Re: Opening Drawings with Missing Models/Assemblies in Parametric 3.0

Indeed, View Only is a different matter, and won't get the job done for you.

What build are you on?  Until recently there was a requirement to have a license including advanced assembly functionality to employ Drawing Reps.  This was removed in M040 (and Creo 2 M150).  When it is available, you should see Open Rep in the Open pulldown in the File>Open dialog for your drawing, leading to a drawing rep selection dialog which will have All Views and No Views.

Highlighted

Re: Opening Drawings with Missing Models/Assemblies in Parametric 3.0

I'm at M040 and I have those options.  The Open Representation option gives me the same error.  A drawing that I've fixed will let me use that option and does give me that view option dialog.  Oh well, just one more sloppy mess to deal with.  Thanks Matt.

Re: Opening Drawings with Missing Models/Assemblies in Parametric 3.0

Looks like my memory of how that functionality works was incorrect.  Sorry about that!

Re: Opening Drawings with Missing Models/Assemblies in Parametric 3.0

No worries Matt.  Thanks for the help.