cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can Bookmark boards, posts or articles that you'd like to access again easily! X

Pro E graphics run slow from Pro E session started in Remote desktop session.

mark.benson
1-Newbie

Pro E graphics run slow from Pro E session started in Remote desktop session.

Hi



I've been running Pro E on my work desktop accessed via Remote Desktop
Connection.



If I connect to an existing ProE session, I get performance which is
adequate for what I want to do.



If I start a new Pro E session from within the remote desktop session,
the Pro E graphics are slow to highlight. This makes it so slow I can't
work effectively.



The Pro E session is still slow when I am back at my workstation.



Does anyone know of any configurations for Remote Desktop Connection, or
Nvidea graphics card which would make it behave the same whether
connected via Remote or sitting at my desk.



Graphics Card: Nvidea Quadro FX 1800

Windows 7 64Bit

ProE 32bit

Release: Wildfire 4.0

Pro/ENGINEER Date Code: M140

Pro/ENGINEER Machine Type: I486_NT

Pro/ENGINEER Graphics Type: OPENGL

OS Name: Windows NT

OS Release: 5.0

OS Version: 2195

Hardware Type: Intel64 Family 6 Model 30 Stepping 5 GenuineIntel 2793
MHz



Thanks



Mark


Fisher & Paykel design starts with you in mind, check out the people and passion behind every Fisher & Paykel product.

6 REPLIES 6

That's a penalty you pay. Some programs won't even run. I tried Ansys
Workbench with no success, but Ansys runs okay though. It seems to have to
do with the graphics mode used for VPN.
byork
17-Peridot
(To:mark.benson)

Mark,



I have been using radmin.

Over a remote session, you will need to set the graphics option to win32_gdi. Your config.pro for that session should have this:
graphics win32_gdi

It's not great performance, but it's better than the opengl.

David Haigh

We tried a trial version of Ericom Blaze along with setting graphics to win32 and performance was very good.

Another way to set the graphics is to use the -g: option in the Pro/E launch command as follows:

...\bin\proe.exe -g:win32_gdi

Mike Foster
ATK
ShandRonnie
5-Regular Member
(To:mark.benson)

You need to restart the Pro/E session for that particular graphics configurations to work.
What I do is have a different start icon (with a different Start-Up directory) in my desktop that loads a separate config.pro ( with this line: graphics win32_gdi).
Another option is to open with Notepad your config.pro (prior to launching Pro/E) and change the graphics from opengl to win32_gdi).

This is a limitation of remote desktop that can be circumvented by starting ProE in the console session.

See: https://community.ptc.com/t5/System-Administration/Response-to-Article-CS115746-Windows-Remote-Deskt...

Announcements
NEW Creo+ Topics: PTC Control Center and Creo+ Portal