cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - When posting, your subject should be specific and summarize your question. Here are some additional tips on asking a great question. X

Screen Flicker

dgschaefer
21-Topaz II

Screen Flicker

Creo 2, M120 & WF4, M220

Over the Christmas holiday, Santa brought me a pair of nice new Dell U2414H monitors.  The IT guy got them set up on my desk and plugged into the docking station for my M6800 laptop, which I had with me at home.  They work great and, combined with the 17' laptop screen, give me a wonderful panorama.

However, whenever I launch either WF4 or Creo 2 (I haven't tried WF5 or SW yet), the screen flickers.  It seems like Windows is clicking "aero" off and then back on.  Once it launches, everything seems to be fine.

No other changes to my system other than plugging in two new monitors.  I had a single, older Dell 24' screen before (I don't recall the model).  My M6800 is running an NVIDIA K3100M graphics card and also has an Intel HD Graphics 4600.  In the NVIDIA Control panel, it shows the NVIDIA card running the 2 LCDs and the Intel running the laptop display.

Any idea how to stop the flickering?

--
--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
6 REPLIES 6

I just tested WF5 and SW 2013 & 2014.  They all produce the same flicker at startup.

--
--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn

It has something to do with the graphics drivers. Prior to my new hard drive I did not have the problem now when I am in pro and go to a windchill screen that has graphics in it I get great strobe and black out effects. Happens at startup too. Attached is video showing my problems. I think it can not decide which graphics driver to use and flashes back and forth between intel and nvidia.

Ron
Chris3
20-Turquoise
(To:dgschaefer)

I had this happen to me recently as well. I turned off “Enable Desktop Composition” in the SystemPropertiesPerformance.exe dialog box. This turns off the transparency in windows but it prevented Windows from switching between the Aero and Classic color schemes which is what is causing the flickering.

dgschaefer
21-Topaz II
(To:Chris3)

Essentially, what I'm getting (and still do with an updated graphics driver), is the toggling of that setting.  It's on, but when a CAD application launches (All flavors of Creo, roe, SW and Draftsight), it turns it off then back on again.  I could turn it off full time, as you've done, but I like having it on and everything runs fine except for the flicker at launch.

What's odd is that it didn't do this with my old setup which was a single external LCD plus my laptop display.  Same laptop, same graphics drivers, just new screens.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
Chris3
20-Turquoise
(To:dgschaefer)

Similar issue. My setup was working fine until IT took my machine to install a new hard drive. After getting it back I had the issue. I tried lots of different drivers with no luck. It lasted ~30 seconds on my machine (less on some of my colleagues machines) and reordered all of my windows which made it really irritating.

If I turn off one of my non-laptop screens the issue goes away as well, but that is more painful.

After a year and a half of flashing screens, including several graphics drivers and builds of Creo, I installed the latest video driver from Dell (353.82) this morning and the screen flashing is now gone.

Capture.JPG

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
Top Tags