cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about PTC Community Badges. Engage with PTC and see how many you can earn! X

Unable to start Creo Platform Agent on CREO 4.0 M050

fafa
5-Regular Member

Unable to start Creo Platform Agent on CREO 4.0 M050

hello everyone ! 

I get an issue about the new platform agent of creo named "Creo Platform Services" . I installed the version Creo 4.0 M050 on server Microsoft 2016 : 

1st issue : platform services failed with the assistant of Installation

Solution: I decided to install myself in the folder (C:\myfolder\\MED-100WIN-CD-410_M050_Win64\install\addon\creosvcs_64.exe) and the installation of parametric and simulate successful 

When I launch Creo 4.0 from the server everything is OK and can connected to windchill

 

However when I launch Creo from an customer pc with a file .bat , Creo works but unable to start Creo Platform Agent ... 

I retried to install 3x times but still the same  message, I also tried to set the env path in the bat but nothing happen .... I don't understand why from the server is ok but failed with the .bat ....

 

In attachment, you'll see the screenshot of the message.

 

Is anyone can help me please ?

 

Thanks in advance.

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

As you can see in @TomU's example, the environment variable CREO_AGENT_EXE_PATH must point to the file creoagent.exe!

View solution in original post

4 REPLIES 4
TomU
23-Emerald IV
(To:fafa)

There are some extra things you have to do to run Creo from a shared network location.  Here are the settings I'm using (your file paths will obviously be different)

 

Additional environment variables (these can be set in the .bat file or the .psf file):

ENV=CREO_AGENT_EXE_PATH=H:\Creo 4.0\M050\Agent\creoagent.exe
ENV=CREO_AGENT_LDP_LIST=H:\Creo 4.0\M050\Platform\4\manifests

 

Additional config.pro (or config.sup) settings:

quality_agent_path H:\Creo 4.0\M050\DiagnosticTools\x86e_win64\obj\qualityagent.exe

 

Here is some related documentation:

fafa
5-Regular Member
(To:TomU)

Thank you for your answer.

 

According to " Guide Installation creo 4.0 pdf " , Creo does not require the environmental variable CREO_AGENT_EXE_PATH to find the path creosvcs_64.exe.

In my previous version of creo (CREO 3.0) I doesn't need to set the environmentale variable in the .bat file or .psf file and the connection with creo platform agent was succesful ... that's why I don't understand the need to set it.  

 

Furthermore, I tested your advice by setting (in my case): 

 

SET CREO_AGENT_EXE_PATH="J:\Creo 4.0\M050\creosvcs_64.exe"
SET CREO_AGENT_LDP_LIST="J:\Creo 4.0\M050\Common Files\manifests"

 

and nothing happen ... should I also define the Windows environmental variables in client's Pc ? 

 

 

As you can see in @TomU's example, the environment variable CREO_AGENT_EXE_PATH must point to the file creoagent.exe!

TomU
23-Emerald IV
(To:fafa)

Setting the environment variables in the .bat file, the .psf file, or on the local computer will all have the same effect.  I would suggest double checking your paths (from the perspective of the client computer.)

Top Tags