cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can subscribe to a forum, label or individual post and receive email notifications when someone posts a new topic or reply. Learn more! X

Weld Edge Prep Questions

DanMcCaherty
1-Newbie

Weld Edge Prep Questions

Years ago when we were putting together a standard modeling process for the usage of weld features in Pro/E, we decided against using weld edge prep due to a variety of reasons I will not go into here, but we recently decided to revisit this decison in Wildfire 5.


Yesterday I built a couple of weld features with edge prep and founda couple ofissues:


Issue #1) It appears that the only weld joint types supported for edge prep are bevel groove & vee groove weld joints. All other types (J grooves, U grooves, etc) don't even come close to accurately defining the actual joint edge prep geometry, or they don't even appear as options in the dialog box.


Issue #2) The related config settings for edge prep don't seem to work. I defined mine such that my bevel groove edge prep should be driven by the part rather than the assembly. That works, but I believe that was set up as the default behavior, so my setting changed nothing. The rest of the config settings I defined appear to get ignored. I wanted my generic model (assembly) to contain the edge prep and welds. I wanted my instance to have those features suppressed. I set my config options accordingly, but I get the oppposite behavior. And all of the other config settings relative to edge prep are ignored as well (angle size, depth, instance suffix name, etc).


Issue #3) I really did not want a new instance automatically created at the part level. I want the feature to appear at the part level, but not in a new Family Table instance. If that part was already a Family Table part, then I would expect the edge prep featureto get added to the generic, and whatever instance was used in the assembly that was included in the assembly where that edge prep feature was created.


So (finally), here are my questions:


Q#1) Does anyone actually use the edge prep functionality?


Q#2) If the answer to #1 is YES, then how do you work around the missing joint types?


Q#3) If the anser to #1 is YES, then do you see the same issues I tried to describe in Issue #2 above?


Q#4) If f the answer to #1 is YES, then is there a way to avoid theproblem I tried to describe in Issue #3 above?


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
0 REPLIES 0
Top Tags