cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't access Twx Composer - Connection refused

nairobi22
4-Participant

Can't access Twx Composer - Connection refused

Hi, I'm new to ThingWorx and in general an IT newbie.

 

I installed the 120 day Trial Edition 8.2 on Windows 7 Enterprise SP 1.

Also installed Docker/Oracle Virtual Box.

Yesterday completed the installation, but now I can't accsess the Composer via http://192.168.99.100:8080/Thingworx/Composer/ anymore.

It says "ERR_CONNECTION_REFUSED".

 

DockerMachinePTC running well in Virtual Box

 

Hope, you can help me.

 

Regards

nairobi

3 REPLIES 3
jkaczynski
4-Participant
(To:nairobi22)

Hi, @nairobi22,

 

Have you started a Tomcat service? Could you please check the Tomcat / ThingWorx logs? You can find them in the directory where Trial version of ThingWorx is installed.

 

BR,

JK.

nairobi22
4-Participant
(To:jkaczynski)

So today the Composer works again... :D

I will try to sum up my problems:

First I installed Docker as pre requirement, and than started the installation of the ThingWorx Trial Version.

A DockerMachinePTC was created in Oracle Virtual Box.

 

After all of that the Composer worked, but i couldn't start the VM DockerMachinePTC out of the Virtual Box Manager [Code: Callee RC: E_FAIL (0x80004005)]

Yesterday I could start the DockerMachinePTC normally but could not access the Composer.

Now I can access the Composer again, but can't start the DockerMachine :D

 

Between all of that I don't remember changed anything on purpose.

 

I don't remember anything related to Tomcat during the installation or as a requirement, is that an alternative to Docker or comes Tomcat with the Trial Version?

 

Attached the install.log, maybe that helps

 

 

nairobi22
4-Participant
(To:nairobi22)

Hello again.

So after a couple of days, where I could access the Composer without problems, but still couldn't start
the DockerMachinePTC via VirtualBox (assuming it has to run for Composer, but doesn't show it), now I can't accsess neither Composer nor the VM.

 

I reinstalled everything, log files attached, but still have the same problems.

 

Hope, you can help me with this.

 

Best regards,

Nairobi

Announcements