cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Have a PTC product question you need answered fast? Chances are someone has asked it before. Learn about the community search. X

Contained Mashup not loading in collection widget

Carl985
10-Marble

Contained Mashup not loading in collection widget

Hi 

I have a base mashup containing several text fields and value displays and a contained mashup which loads data when the thing name is passed to it. The contained mashup works by its self and on other mashups it is present on.

Carl985_0-1641557582974.png

But when used with the collection widget the contained mashup does not load and I get the message (could not load "MASHUP_NAME" reason 0 undefined"

 

Carl985_1-1641557773737.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
slangley
23-Emerald II
(To:Carl985)

HI @Carl985.

 

From the case that was opened, I saw that you found a workaround by using nav functions to open the displayed contained mashups on another page, which had no impact on how the mashup displays.  It's my understanding a fix is targeted for ThingWorx 9.3.2.

 

Please confirm that the above is your understanding.

 

Regards.

 

--Sharon

View solution in original post

4 REPLIES 4
slangley
23-Emerald II
(To:Carl985)

Hi @Carl985.

 

It's likely that you're missing some bindings at the parent level.  Have you tried using the debug tools for tracking it down?  This example may help you to pinpoint the issue even though the post is regarding a different use case.

 

If you need some assistance, please let me know what version of ThingWorx you're running, and I'll be happy to open a case on your behalf.

 

Regards.

 

--Sharon

Hi @slangley,

 

I have an open case with tech support thanks for your reply

slangley
23-Emerald II
(To:Carl985)

HI @Carl985.

 

From the case that was opened, I saw that you found a workaround by using nav functions to open the displayed contained mashups on another page, which had no impact on how the mashup displays.  It's my understanding a fix is targeted for ThingWorx 9.3.2.

 

Please confirm that the above is your understanding.

 

Regards.

 

--Sharon

Hi Sharon

 

You are correct the problem is to do with the layout selection. If the layout is set to static in the base mashup the contained mashup does not display correctly when used in a contained mashup. From my contact with tech support the fix has been tested in 9.3.1 pre release and works

 

Regards

 

Carl

Top Tags