cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

EMS timed out

Highlighted
Regular Member

EMS timed out

Hello,
I am trying to connect a Raspberry pi to Thingworx platform vis EMS. When running ./wsems command, I have a time out issue. Here is my log file.
[DEBUG] 2020-01-30 10:50:15,708 SDK: twTlsClient_Connect: Connecting to server
[INFO ] 2020-01-30 10:50:15,761 SDK: Server supports websocket extensions: permessage-deflate
[DEBUG] 2020-01-30 10:50:15,761 SDK: ws_on_headers_complete: Websocket connected!
[INFO ] 2020-01-30 10:50:15,761 SDK: twWs_Connect: Websocket connected!
[DEBUG] 2020-01-30 10:50:15,762 SDK: twWs_SendMessage: Sent 60 bytes using 1 frames.
[WARN ] 2020-01-30 10:50:25,784 SDK: api:sendMessageBlocking: Message 2 timed out
[DEBUG] 2020-01-30 10:50:25,784 SDK: twOfflineMessageStore_Write: Stored message in offline msg file. RequestId 2
[DEBUG] 2020-01-30 10:50:25,784 SDK: twMessage_Delete: Deleting AUTH Message: 2
[INFO ] 2020-01-30 10:50:25,784 SDK: twMessageHandler_CleanupOldMessages: Message 2 timed out

 

Can anyone please find me a solution ? 

2 REPLIES 2
Highlighted

Re: EMS timed out

Hi,

 

Please upload a screenshot of WSCommunicationSubsystem , need to see what timeout value is set.

 

Thanks,

Raluca Edu

Highlighted

Re: EMS timed out

Thank you for your answer, here is the sreenshot: 

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!