cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Error loading Drag and Drop File Upload Widget

SOLVED
Regular Member

Error loading Drag and Drop File Upload Widget

At runtime, the Drag and Drop File Upload Widget is not showing.in the chrome browser.

Anyone who already had this issue and knows how to resolve it ?

Here is what I have done, what seems to work, and what doesn't seem to work:

  • I have succesfully imported the extension, version 1.3.0 into Thingworx 8.0
  • I can see in the Thingworx Monitor - Extensions tab that the dndfileupload Widget is contained in the package.
  • In Thingworx Composer, I can pick the "Drag and Drop Upload" widget and drag it into my mashup. In the mashup builder I see the blue "drop area".
  • I have linked the drop area with the SystemRepository and set the path to "/"
  • When Viewing the Mashup in the Chrome Browser, the Drag and Drop Upload widget does not appear
    • When clickin Show/Hie Log, there is the following error:
      • ERROR - TW.Runtime.Workspace.Mashups.getWidget exception loading widget { name: Error, message: dndfileuploaddoesn't exist
  • When viewing the same mashup in Mozilla Firefox, the green Drag and Drop zone is displayed, and works as expected
  • In Internet Explorer, the runtime mashup doesn'n show up at all...


Tips are appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Error loading Drag and Drop File Upload Widget

Solved by unchecking "Display intranet sites in Compatibility View" checkbox in Compatibility View Settings of Internet Explorer.

Strange enough this also solves the issue in Google Chrome.

2 REPLIES 2

Re: Error loading Drag and Drop File Upload Widget

Please note that the extension has been tested and certified for ThingWorx 7.2 but is no longer supported.

ThingWorx IoT Marketplace

Re: Error loading Drag and Drop File Upload Widget

Solved by unchecking "Display intranet sites in Compatibility View" checkbox in Compatibility View Settings of Internet Explorer.

Strange enough this also solves the issue in Google Chrome.