cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

From where should I download Older versions of Thingworx extension SDKs and plugin?

SN_10063805
1-Newbie

From where should I download Older versions of Thingworx extension SDKs and plugin?

I have previously made Thingworx Extension with source code. But for setting Eclipse environment, following is required:

1. ThingWorx-Extension-SDK-8-3-0.zip

2. twx_eclipse_plugin_version =7.2.0.201608021836 

Please provide the link to download the same versions of SDKs and Plugin.

 

I could get the latest versions ,

but for my Extension project old versions of SDK & Plugin is required.

 

SN_10063805_0-1640193402020.png

 

3 REPLIES 3
VladimirN
23-Emerald IV
(To:SN_10063805)

Hi,

 

 

Article - "How to install Eclipse Plugin for ThingWorx Extensions and the required Extension SDK": https://www.ptc.com/en/support/article/CS233537 

From the "Help Center" - "Installing the Eclipse Plugin for ThingWorx Extension Development": https://www.ptc.com/en/support/article/CS233537 

Hi@SN_10063805 

Two questions for clarification - please answer each of them:

-are you really developing an extension for a ThingWorx 8.3 server? That ThingWorx version has been out of support for a long time.  Or you want to upgrade an extension you previously designed for ThingWorx 8.3 to a more recent ThingWorx version?

-you mentioned "for setting Eclipse environment, following is required:...", Why do you say this? Please share exactly what you tried to do, and what error you encountered. I am aware that you pasted the contents of the extension.properties found in the project workspace folder of the extension, but that does not mean it is "required".

 

 

 

Announcements