cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Grid Widget Foreground Style Issue

Highlighted
Level 8

Grid Widget Foreground Style Issue

Hi,

I'm having an issue with the standard grid widget style in that it won't display the foreground colour correctly in the rows. The header seem to work correctly but the rows will not change their foreground (font) colour. I can change the style of the widget and all the other changes (background etc.) display the changes, but the font remains grey. If I hover over a row then it displays.

Some other points of interest are:

  1. If I use built in styles then it works fine, only an issue with style definitions I have created.
  2. If I use my styles with any other widget it works fine.
  3. I have 2 instances of the composer on 2 servers (development [7.3.0-b51] & test [7.3.13-b22]). I exported all the entities from development to test server. It works fine on the development server.
  4. I have tried re-importing the styles & mashup numerous times.

In the mashup below the mashup itself has a black background and I'm trying to show a white fond in the grid widget

   

I'm I doing something silly or is there a way around this?

Thanks in advance

K

2 REPLIES 2

Re: Grid Widget Foreground Style Issue

Kieron Hayes​ : Since it is working on an one instance it seems to be an issue specific to an environment. Did you tried checking post clearing browser and tomcat cache on the instance where you are observing this UI issue.

-Durgesh

Re: Grid Widget Foreground Style Issue

Hi, thanks for the suggestion. I have tried that, but it didn't fix the issue.