cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need help navigating or using the PTC Community? Contact the community team. X

Install ThingWorx Flow with ThingWorx 9.1.0 without internet connection

seanccc
17-Peridot

Install ThingWorx Flow with ThingWorx 9.1.0 without internet connection

Hi,  

I'm installing ThingWorx Flow on ThingWorx foundation 9.1.0, both of them are to be installed in the same machine. 

According to the installation guide: https://support.ptc.com/help/thingworx/platform/r9/en/index.html#page/ThingWorx/Help/Integration_Orchestration/InstallingTwxFlowPostgreSQL.html

I should run the following commands firstly in a machine which has internet access, let's call it machineB: 

◦ yum install 'nginx'
◦ yum install 'rh-nodejs8'
◦ yum install 'rabbitmq'
◦ yum install 'openssl'
◦ yum install 'policycoreutils-python'
 
However,  yum install 'rh-nodejs8' and ◦ yum install 'policycoreutils-python' get failed (the other  3  packages are installed): 
yum install 'rh-nodejs8'
Updating Subscription Management repositories.
Extra Packages for Enterprise Linux Modular 8 - 142 kB/s | 528 kB     00:03    
Extra Packages for Enterprise Linux 8 - x86_64  684 kB/s | 8.7 MB     00:12    
PostgreSQL common RPMs for RHEL/CentOS 8 - x86_ 139 kB/s | 533 kB     00:03    
PostgreSQL 13 for RHEL/CentOS 8 - x86_64         69 kB/s | 216 kB     00:03    
PostgreSQL 12 for RHEL/CentOS 8 - x86_64        150 kB/s | 408 kB     00:02    
PostgreSQL 11 for RHEL/CentOS 8 - x86_64         28 kB/s | 604 kB     00:21    
PostgreSQL 10 for RHEL/CentOS 8 - x86_64         28 kB/s | 422 kB     00:14    
PostgreSQL 9.6 for RHEL/CentOS 8 - x86_64        30 kB/s | 409 kB     00:13    
PostgreSQL 9.5 for RHEL/CentOS 8 - x86_64       118 kB/s | 365 kB     00:03    
Red Hat Enterprise Linux 8 for x86_64 - BaseOS  3.5 MB/s |  26 MB     00:07    
Red Hat Enterprise Linux 8 for x86_64 - AppStre 1.4 MB/s |  25 MB     00:17    
Last metadata expiration check: 0:00:01 ago on Tue 29 Dec 2020 12:14:36 AM PST.
No match for argument: rh-nodejs8
Error: Unable to find a match: rh-nodejs8
 
# yum install 'policycoreutils-python'
Updating Subscription Management repositories.
Last metadata expiration check: 0:01:09 ago on Tue 29 Dec 2020 12:14:36 AM PST.
No match for argument: policycoreutils-python
Error: Unable to find a match: policycoreutils-python

 

I'm using REHL 8.2  and have no idea why the package cannot be found  ? 

 

Furthermore,   for the 2nd step of the guide: 

2. Configure the yum package manager on the box where you plan to run the installer to set this box as a yam dependency.

I don't really get it ,  does it means the machineA (without internet access ) must be able to connect to the  machineB (has internet access  and has yum packages installed) and set the yum dependency to it ?   In my customer's environment,  machineA  cannot connect to machineB,  so how to install flow ?   Please help .

 

Regards,

Sean

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Jimwang
15-Moonstone
(To:seanccc)

you may refer to the below article to update your RedHat repository so that the RPM packages are available:

https://developers.redhat.com/hello-world/nodejs#

 

View solution in original post

5 REPLIES 5
odukiya
15-Moonstone
(To:seanccc)

Hello @seanccc 

 

 As I can understand from what is mentioned in the link shared by you is that you need to have internet connection as it is designed to work like that . In your case your machineA should have internet connection or it has to connect with other machine which have internet.

 

"The ThingWorx Flow installation tool on Red Hat Enterprise Linux is designed to work with an internet connection. If you plan to install ThingWorx Flow on Red Hat Enterprise Linux without an internet connection ..."

 

Thanks

Om Dukiya

seanccc
17-Peridot
(To:odukiya)

@odukiya ,

 

But even on machineA,  yum install the following two packages got failed : 

 

yum install 'rh-nodejs8'
yum install 'policycoreutils-python'

seanccc
17-Peridot
(To:seanccc)

sorry,  even on machineB which has internet access,  yum install the following two packages got failed : 

 

yum install 'rh-nodejs8'
yum install 'policycoreutils-python'

Jimwang
15-Moonstone
(To:seanccc)

you may refer to the below article to update your RedHat repository so that the RPM packages are available:

https://developers.redhat.com/hello-world/nodejs#

 

slangley
23-Emerald II
(To:seanccc)

Hi @seanccc.

 

If you feel your question has been answered, please mark the appropriate response as the Accepted Solution for the benefit of others with the same question.

 

Regards.

 

--Sharon

Top Tags