cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need help navigating or using the PTC Community? Contact the community team. X

IoT Hub Connector & Ports

gch
12-Amethyst
12-Amethyst

IoT Hub Connector & Ports

Hello,

 

I have a Thingworx application installed on a development environment and using the IoTHub connector. We are able to receive files from Azure through the IoT Hub connector.

On a future production environment we are not able / allowed to open ports on the Thingworx machine. The communication to Azure should be possible, but no port opened from azure to the connector. Will the IoTHub connector work correctly? Do you know which ports should be opened to use the IoT Hub connector?

1 ACCEPTED SOLUTION

Accepted Solutions

There is no inbound port opened from Azure to our connector.

The outbound ports are mentioned in the Azure documentation, since they are specific to Azure IoT Hub, https://learn.microsoft.com/en-us/azure/iot-hub/iot-hub-devguide-protocols . We don't use the Websockets parts. But again, these are outbound ports, so most probably you do not need to setup anything - except if your IT infrastructure is strict and by default blocks these ports as well.

View solution in original post

7 REPLIES 7
VladimirN
24-Ruby II
(To:gch)

 Hi,

 

gch
12-Amethyst
12-Amethyst
(To:VladimirN)

Thank you, I already had a look to this documentation but I could not find any ports used except 9009 used by the health monitor but Optional

gch
12-Amethyst
12-Amethyst
(To:gch)

Hi, Any other information on the required port communication on the IoTHub connector machine?

Hey Hi @gch,

I have the same Senrio, we shouldn't open any PORT on PROD. So I have used port 80. So twx opens when iot.ABC.com:80 also opens up iot.ABC.com. That's how port 80 works.

Or you can try port 443 if the URL is in HTTPS.

Thanks,

Shashi Preetham

Hi Shashi, Port 80 / 443 are used for the communication with Thingworx which is not a problem since inside the Network, the issue is the communication to the outside / to Azure where it is not clear to me if or which port are used

There is no inbound port opened from Azure to our connector.

The outbound ports are mentioned in the Azure documentation, since they are specific to Azure IoT Hub, https://learn.microsoft.com/en-us/azure/iot-hub/iot-hub-devguide-protocols . We don't use the Websockets parts. But again, these are outbound ports, so most probably you do not need to setup anything - except if your IT infrastructure is strict and by default blocks these ports as well.

gch
12-Amethyst
12-Amethyst
(To:VladimirRosu)

Excelent Vladimir, thank you so much, this is what I was looking for! I opened a PTC case, I got the answer that the ports needs to be opened be according to the link it is not the case. We will see in the praxis, thanks!

Top Tags