cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can change your system assigned username to something more personal in your community settings. X

Issue in pushing remote property using Java SDK

harpreetk
5-Regular Member

Issue in pushing remote property using Java SDK

Using simulated device(Java SDK running in Eclipse), I am connecting to a remote thing and trying to update a property which is defined on Thingworx platform as a remote property, but not able to see the update reflect on the Thingworx platform.

 

I am invoking UpdatePropertySubscriptions method on the Agent. I have tried configuring PushType Always also at the simulator side. Thingworx platform is able to read the property from simulated device, but it looks like that value is not getting pushed from the remote device to the platform. I am using Thingworx 8.5. 

 

If I gave the cache method as "Fetch from remote every read", it will update the value in thingworx platform but this will cause huge performance issue. Cache method as "Read from Server Cache" is not working . It should work if the value is getting pushed from remote.

 

3 REPLIES 3

Hello Harpreet,

 

Have you reviewed the Steam Sensor example provided with the Java SDK? We have a video tutorial on how this can be configured here. This may be able to assist with further details on pushing properties to the Platform as opposed to simply pulling data from the Edge.

harpreetk
5-Regular Member
(To:tmisner)

Hello,

 

Thanks, I reviewed the Steam Sensor video. I am doing in the same way. But it still it looks like property value is not getting pushed from the simulated device. I am getting following error while running JAVA SDK, may be this is causing the issue.

 

"Unable to dispatch [ uri = /Things/SDKThing/Services/GetPropertySubscriptions/]: Unable to Invoke Service GetPropertySubscriptions on SDKThing : null"

 

I tried by giving admin rights to the user, still getting the above error.So does not look like permissions issue.

Hello again,

 

I do apologize for the delay in reply on this matter as I had missed the notification.

 

Are you still encountering this issue? If so my recommendation is that we get a Technical Support case open for the same. I can do this on your behalf should you want to proceed. We can then take a deeper look and investigate the logs from both the Platform and SDK.

Top Tags